Blue Prism University

last person joined: 18 hours ago 

A Community to discuss and learn more about Blue Prism University and certification.

 Consolidated exercise process on runtime resource with login agent

posted 01-19-2021 11:33
I am new to BP and not an IT guy. I'm a data analyst. Please be understanding with my lack of IT knowledge. I am also the sole person using BP where I work. 

BP version 6.9.0

Our ultimate goal is to create and schedule processes to run on BPRUNTIME1 overnight with nobody online to start it. 

I have completed the Consolidated Exercise and another process. Both processes complete on my laptop, but when I use the login agent to run them on the virtual machine (BPRUNTIME1) set up as a runtime resource, they both fail on the first stage.

I am able to run the Stopping Time Exercise on BPRUNTIME1 using the login agent. It appears when BP needs to do something outside of itself, it terminates on the first stage. 

I have checked the file paths. I have logged into BPRUNTIME1 as the windows user that the login agent uses and both processes will complete. 

I don't know if BPRUNTIME1 isn't set up correctly, the login agent isn't set up correctly, or if the processes aren't set up correctly. 

Any help is appreciated!
Hi Austin.

Welcome to the Blue Prism community.

I'm trying to understand the situation you are facing. You use Login Agent to log into BPRUNTIME1 to run your process. Then you say your process, for example the CE (consolidation exercise), fails on the first stage. Is that correct?

How are you starting the CE and what is the exception that you receive? Are you certain the runtime resource is started and available?

A typical use of Login Agent is to simply log into whatever machine that is going to be used to run BP processes. Once the machine is up and the runtime resource started, processes can be executed, for example, from a schedule.

The more details provided the better.

jack
Thank you for replying Jack. 

I'm making some progress on this. I think my problem is my lack of understanding how the login agent and the listener work. 

When I closed my connection to BPRUNTIME1 leaving the resource signed in, I was able to get the process to complete. I thought it logged it and stayed logged in on its own. 

I've looked for information on the login agent and the listener, but haven't found anything. Can someone point me towards the best resource for these? 

I'm also having trouble on another process mentioned above. It uses Global Send Keys to type a report name. Can Global Send Keys be used on a runtime resource?
Hi Austin.

I'm glad that you are gaining ground on the problem. There is a class in the LMS for Login Agent. It isn't very long.

Have a look:  Blue Prism

jack
Hi Austin,

What exactly do you mean by 
   "When I closed my connection to BPRUNTIME1 leaving the resource signed in, ..."
?

You're not supposed to have any connection (e.g. via Citrix or RDP) to the runtime resource while the Robot is running there.
The procedure should be as follows:
- once you're done setting up the runtime resource as BP resource PC, you log out from it or better: re-start it (but do not log in there again manually)
- the runtime resource should then appear with the "locked" symbol in Blue Prism Control Room
- then you run the Login Process (manually or via scheduler) on the runtime resource
- once the Login Process completed successfully, the runtime resource often goes offline for a short time (max. 1-2 minutes) before it appears as connected / unlocked again in control room
- then you run your actual business process on this runtime resource (again, you can trigger this manually or via scheduler; if you use the scheduler, make sure there is enough delay - lets say 5 min - after the login process has completed to ensure the runtime resource is up and resource pc running before the business process starts)

If you're still facing issues then, I think it would be helpful to get the detailed error messages from the session logs.

Good luck!
Astrid
Jack: 

I'm getting the below error when I try to follow the link to the training: 

I wasn't able to find it searching in the LMS for "login agent" either. Can you tell me what it is called and I'll search for it?
Hi Austin.

I'm sorry about that. I tested it myself and it was working. Anyway, log into the Blue Prism portal and go to the University link and then select LMS. Search for Login Agent.

You'll find classes there.



jack
Jack: 

I'm starting to think I can't even navigate a webpage. I'm logged into my account on BP -> University -> Training Offering (via LMS) -> "search content in the platform" enter "login agent" and I get this:

Hi Austin.

I have no idea why your search does not provide the LMS class. However, let's try a different approach.

From the portal, go to Documents/Documentation and search for Login Agent (see screen shot below).

Many documents are being moved into the LMS and made into a class structure but Login Agent is there for now.

Jack:

I was able to get the document. I'll get it over to IT. 

Is it possible that my account doesn't have access to the login training?
Hi Austin.

I'm glad you were able to find the doc at least. I don't know why you wouldn't be able to access Login Agent training. 

I suggest you create a new post and ask that question specifically. There are folks monitoring the messages (like me) that know about access issues in the LMS and hopefully one of them will pick it up quickly and get an answer for you.

jack
Jack: 

Will do.

Astrid: I'm getting the document over to IT and hopefully we'll get this figured out (if not I'll be back).

Thank you both for your help!
Astrid:

I tried searching the community for the below error, but didn't have any luck. I also looked at the login agent object and it appears to come from the Authenticate To Windows page. I noticed that page isn't published. I believe we have the listener set up correctly, but when I run the login agent I get this error: 

Dear Austin,

sometimes the issue isn't within Blue Prism and the exception happens somewhere else it's just Blue Prism which catches it and passes the error message on to the user.
So although the Blue Prism community should probably be the first place to search, it shouldn't be the only one :-)
A quick google search for this semaphore timeout error points to some sort of network issue:
https://www.stellarinfo.com/blog/solved-error-semaphore-timeout-period-has-expired/

Are there maybe any firewalls blocking the access of the login agent to your VM?

Cheers
Astrid