Blue Prism Product

last person joined: 7 hours ago 

Chat about Blue Prism products
Expand all | Collapse all

Connection to Runtime Resource lost over time

  • 1.  Connection to Runtime Resource lost over time

    Posted 01-30-2019 18:23
    Dear all, We are running Blue Prism interactive clients on a Citrix session host deployed in the Azure cloud. Furthermore we're running runtime resources as VMs in the Azure cloud. Connectivity between the nodes as well as firewall rules are established correctly and I can see the runtime resource in the "Control Room" being "Logged Out" which is all fine.   However from time to time we see that the interactive clients are loosing the connection to the runtime resources and the "Control Room" shows these nodes as "offline". If I then connect to the runtime resource using e.g. RDP the nodes appears normally. Hence I think that the login agent may stop working over time, though the service is running properly.   Do you have any idea how I can perform a root cause analysis when this situation happens again? Would really like to fix this properly.   Furthermore I was wondering if Blue Prism has any means to check if the runtime resources are in the desired stage "Logged Out" and if not alerting someone?   Hope this makes some kind of sense. Best Regards, Stefan


  • 2.  Hi there, We are having the…

    Posted 04-03-2019 14:56
    Hi there, We are having the same issue. Could you please tell me how you resolved this one? 


  • 3.  Hi, I think many of us are…

    Posted 04-03-2019 16:19
    Hi, I think many of us are experiencing this.  We have the same isseu and we are not currently using VMs. At first I thought this may be due to insufficient network pipeline or under resources application server.  i have not been able to diagnose the root cause on our environments yet. At the same time, the listener on each resource is likely also contributing to the problem. While I have no fix (yet),we have had some benefit when we simply turn everything off and on again.  Restarting DB and App server.  Then restarting each Run time resource.  Usually reduces the number of events we experience. Hope someone or BP themselves comes up with a proper solution though. Kind regards Ben


  • 4.  RE: Hi, I think many of us are…

    Posted 07-05-2019 04:55
    I am also experiencing this error from time to time. So far no solution, except restart.

    Worst thing is, some work items are lost as a consequence. This is really bad :(

    ------------------------------
    Andrea Frauchiger
    Senior Consultant
    Synpulse AG Management Consulting Switzerland
    Europe/London
    ------------------------------



  • 5.  RE: Connection to Runtime Resource lost over time

    Posted 07-09-2019 06:19
    We also experienced the issue to lose runtime resources over time.
    As far as I can remember this was before we applied recommended Windows policies on those VMs.

    After we applied the policies it became better. Since we also have a small helper running on those VMs that emulates activities, so Windows and VM does not go into any sleep or idle mode, we have much more stable process executions and runtime resources are up and available over the span of several days without any manual interaction necessary.
    We are using the tool Caffeine to emulate pressing shift key every couple of minutes.
    You might want to give it a try as it is easy to verify and might give you further hints for investigation.

    ------------------------------
    Walter Koller
    Solution Manager
    Erste Group IT International GmbH
    Europe/Vienna
    ------------------------------



  • 6.  RE: Connection to Runtime Resource lost over time

    Posted 04-08-2020 10:58
      |   view attached
    We are facing the same issue in production. We face this while we have a long running process.So far we worked with our network and VM support teams. 
    The pain is we have to re run the process and those already added to Queue will be obsolete. Attached is a screenshot how it looks. I will update once I hear back from BP tech support.

    ------------------------------
    Manas Jena
    Sr Analyst
    ZimmerBiomet
    America/New_York
    ------------------------------



  • 7.  RE: Connection to Runtime Resource lost over time

    Posted 06-23-2020 05:49
    Dear Manas,

    did you meanwhile get feedback from BP tech support?
    Would be interested to hear if there is anything we can do to reduce or even avoid these issues.

    Thx & regards,

    ------------------------------
    Astrid
    ------------------------------



  • 8.  RE: Connection to Runtime Resource lost over time

    Posted 09-25-2020 07:21
    Most of the time, losing connectivity is because of an external factor. when this happens we advise checking the Runtime Resource connection against the Blue Prism Server (ping response time, DNS, tracers, etc). we provide a guide on how to follow tests and get the results to analyze by your team or with us to determine the possible cause.

    Please contact us at support@blueprism.com or create a ticket in the Portal.

    ------------------------------
    Luis Lopez
    Customer Support Engineer English and Spanish
    Blue Prism Ltd
    ------------------------------