Blue Prism Product

last person joined: yesterday 

Chat about Blue Prism products
Expand all | Collapse all

Scheduler - Timed out waiting for valid connection

Jump to Best Answer
  • 1.  Scheduler - Timed out waiting for valid connection

    Posted 04-28-2017 09:41
    Hi, I have scheduled a process in Lower environment (DEV) and the same in Higher environment (PROD). In DEV, the scheduler works properly, but it fails with the following error message in PROD (while checking the scheduler log). "Resource XXXXXXXX : Timed out waiting for valid connection" If I manually drag the process to a resource in the control room, the process runs fine. But fails to kick off if I schedule the same process on the same resource. Please refer to the attached image. I have verified that all the scheduler settings in Blue Prism are the same for both the environments. Can Somebody please help me out finding a solution for this?

  • 2.  Behind the scenes manually

    Posted 04-28-2017 15:50
    Behind the scenes manually starting in control room is a direct telnet/tcp command between your pc and the production resourcepc. However, behind the scenes schedules are started off by a direct telnet/tcp command between the application server rand the production resourcepc. The next thing for you to investigate therefore is your connectivity between the application server and the resourcepc.

  • 3.  Hey do you have a solution

    Posted 05-31-2017 15:51
    Hey do you have a solution for this Problem? i have the same Problem.

  • 4.  I see this problem pretty

    Posted 06-05-2017 21:44
    I see this problem pretty regular. I've completed all relevant connectivity tests, but still unable to find the cause of this problem. A restart of the Application Server service resolves this for me.

  • 5.  RE: I see this problem pretty

    Posted 07-31-2019 12:14
    I have similar problem and restarted the machine couple of times, still it doesn work.

    Sunil Sharma
    Senior Consultant

  • 6.  I can confirm that restarting

    Posted 09-20-2017 12:16
    I can confirm that restarting the Application Server worked for my team aswell. We been through several troubleshooting steps before hand, but this did the trick! Thanks a bundle! =) /Søren

  • 7.  I'm having this issue as well

    Posted 09-26-2017 14:20
    I'm having this issue as well, are you on I agree, that a restart of the App server and relevant Resource Machines resolves the issue, but it seems to happen on a weekly basis. Wondering if there's a root cause, or a known Blue Prism bug with this version.

  • 8.  Retart of the application

    Posted 09-27-2017 10:26
    Retart of the application server did the trick for us as well. Support Execitives of my team is mulling over the idea of having the Application Server weekly identifying the low/nill load time.

  • 9.  Hi all,

    Posted 10-02-2017 19:27
    Hi all, we faced this same issue and were looking for couple of days how to fix (without restart). In the end a simple trick helped: - setting the resource to “retired” in „System Manager“ > „Resources“. - starting the startup script results now fairly with the message: Listener failed : Unable to register with the database - Cannot register resource PC xxxx because it has been retired - now activate the resource again in System Manager and restart the startup script. Afterwards the Scheduler was able again to connect to the resource PC. As this changes nothing on the resource it seems like a bug with the Scheduler. It would be appreciated if Blue Prism can fix this problem. best regards

  • 10.  RE: Hi all,

    Posted 25 days ago
    Edited by Chetna Agarwal 25 days ago
    Hi ​Alex,

    Trick you provided worked for me and saved my time from restarting Production server and business loss. Thank you so much.

    Chetna Agarwal


  • 11.  Hello,
    Best Answer

    Posted 12-04-2017 19:57
    Hello, Having to create an RFC every time we need a reboot is not really convenient so we tried Alexander Bopp's work around and it worked very well. Terminate automatec.exe on the resource Retired the resource Waited a few seconds Un-retire I hope Blue Prism is working on fixing this issue though. thanks Carol