Blue Prism Product

last person joined: yesterday 

Chat about Blue Prism products
Expand all | Collapse all

Issue with process : Not recognizing an element

  • 1.  Issue with process : Not recognizing an element

    Posted 07-11-2017 14:19
    Hi, I am automating an browser task. In that after logging in to the website, I am searching some text and then once that text comes up , clicking on the tab and doing the further operation. When I executed it directly from object, it executed successfully but when I executed it by calling same object from process, it stuck after searching the text, not able to recognize the the tab that comes up . I even added a wait stage with a label element "Check Exist" (just to verify if I am on right tab), even teh wait time is of 15 sec. Everything works well when I directly run the object but it didnt work when I run the same object via process. Also other elements of this objects are running fine directly as well as through process, so I thought of alighning "Properties " for the spy element of this tab with other elements, still no luck. Object is accepting two elemements of type text from process. Please can someone provide some direction.


  • 2.  RE: Issue with process : Not recognizing an element

    Posted 08-13-2020 18:38
    Hi Narayan,

    I'd suggest you to work on intelligent wait stage and apply best practices to fix this problem.

    The Process studio and control room may run faster than the Object studio.
    So placing the wait stages are important to get it also run well in Process studio. You want to make sure they have enough wait time before it gets timeout.
    Many may have thought having wait stage is unnecessarily and it has been complicating and slowing down the process. It is definitely not.

    Please note it is important to use intelligent wait stages to ensure the application that you are expecting is ready to go.

    Thanks,
    In Joe

    ------------------------------
    In Joe Khor
    Sr. Product Consultant
    Blue Prism
    ------------------------------



  • 3.  RE: Issue with process : Not recognizing an element

    Posted 08-14-2020 04:09
    To add to InJoe's good advice, a key principle when developing integration logic is to ensure BP keeps with the pace of the target application. Without the intelligent waits recommended above, BP will race ahead and attempt to find elements that may not be available yet. With that in mind, the best approach is to avoid going too far with object development before stopping and testing actions in process studio and then in control room. The mantra is 'control room is the only test that counts', and anything that worked before you tried in control room is almost certainly due to the increase in running speed.

    I know this isn't an answer as such, but when you get these problems the first place to look is at the synchronisation between object and application.

    ------------------------------
    John Carter
    Professional Services
    Blue Prism
    ------------------------------



Share