Blue Prism Product

last person joined: 17 minutes ago 

Chat about Blue Prism products
Expand all | Collapse all

No permission to debug/processvalidation?

  • 1.  No permission to debug/processvalidation?

    Posted 01-30-2020 05:23
      |   view attached

    Hi all,

    When I am trying to debug a process or an object, I can't get the list of errors appear. Instead I receive an pop-up error message stating I don't have the correct Permission to do this action. If I click 'ok' on this message, it disappears and then a blank list of errors appears (see printscreen in attached word doc). Even if the process is saying that I have 5 errors in the list, The actual list for debugging will remain empty/blank.

    Does someone have an idea to fix this? Is this linked to a set of permissions I need?
    I have added the details of the pop-up message as attachment.



    ------------------------------
    Jonas Bertels
    RPA Consultant
    BrightKnight
    Europe/Brussels
    ------------------------------

    Attachment(s)



  • 2.  RE: No permission to debug/processvalidation?

    Posted 01-30-2020 12:33
    Best to raise a ticket with support@blueprism.com Jonas

    ------------------------------
    John Carter
    Professional Services
    Blue Prism
    ------------------------------



  • 3.  RE: No permission to debug/processvalidation?

    Posted 09-23-2020 08:31
    Good day.
    Did you get a solution to this problem? The same problem, I think this is due to the use of activities imported from other versions of Bluprism.


    ------------------------------
    Sergei Evdokimov
    ------------------------------



  • 4.  RE: No permission to debug/processvalidation?

    Posted 12 days ago
    Hi Sergei,

    The reply I received solved the issue and can be found below. Hope it helps you as well!

    How to resolve this issue

    This issue has been fixed in Blue Prism v6.6.  

    However, if you are unable to upgrade to v6.6 at the time, then you can still workaround this issue by enabling the 'Audit - Configure Design Controls' permission field for the user role that is unable to debug:

    To select the Audit - Configure Design Controls check box:

    1. Open Blue Prism with an account which has permission to modify security for Blue Prism Roles.
    2. Open the Settings area
    3. Click Security > User Roles.
       
    4. Navigate to the relevant role which that user is assigned to. If you are unsure, you should see the users in the list after highlighting a role.

    Highlight the relevant role

    The user should be in the list at the bottom of the window

    1. Expand the 'System Manager' permissions, and check the Audit – Configure Design Controls option as shown below.
       
    2. Click Apply to assign the changes to the highlighted role.

    It seem I cannot add pictures to this post, but the explanation should provide you enough guidance to get to the correct solution.

    Kr,
    Jonas

    ------------------------------
    Jonas Bertels
    RPA Consultant
    BrightKnight
    Europe/Brussels
    ------------------------------