Blue Prism Product

last person joined: yesterday 

Chat about Blue Prism products
Expand all | Collapse all

Spying in Chrome: Browser Mode not Working in different environments

Jump to Best Answer
  • 1.  Spying in Chrome: Browser Mode not Working in different environments

    Posted 25 days ago
      |   view attached
    Hello all,

    I am witnessing a weird scenario in one of my environments regarding Google Chrome. We have automated a whole process in Chrome beforehand, however, it was not click-intensive so most of the work was done in UIA mode. Now an object was created in our Blue Prism Development Environment using the chrome application and browser mode.

    The interesting thing is that once we enter the test environment of Blue Prism (a different database, a different Blue Prism instance), and we launch the same process, it can no longer identify the items. I do not mean highlight, I mean opening the application modeller and trying to identify a field, browser mode does not work, but the other ones do (UIA, region).

    This was all done on my colleague's machine. Curiously enough, when launched on my computer I can identify and highlight elements in the test environment, but in our development environment, it does not work for me. We are both working with the same versions of Blue Prism, and using the same blue prism chrome extension, and are also on the same network. 

    It is quite important to get the browser mode working as it is able to identify fields much quicker than any other mode.

    Any suggestions or further information needed? 

    I included a gif that demonstrates my issue. I start in test and I am able to identify a field in browser mode, then switch to development and it does not work, then back to test where it works. My colleague is having the same issue but in opposite environments.

    ------------------------------
    James Costa-Arruda
    RPA Developer
    IN-RGY
    America/New_York
    ------------------------------


  • 2.  RE: Spying in Chrome: Browser Mode not Working in different environments

    Posted 25 days ago
    Hi James,

    I had the same issue some weeks ago. Reinstalling the Chrome Extension helped me out.
    Chrome Web Store > Search for Blueprism


    ------------------------------
    Lukas Maier
    RPA Developer
    Vienna
    ------------------------------

    ------------------------------
    Lukas Maier
    ------------------------------



  • 3.  RE: Spying in Chrome: Browser Mode not Working in different environments

    Posted 24 days ago
    Hi James,

    I am also seeing this issue with Chrome.  We are on version 6.5.1 for Blue Prism and Ext 2.1.0 for the Chrome ext.  What versions are you working with currently?  I did come across this thread yesterday that may be of help.  We are working with our IT department for upgrading our version of Blue Prism and are hopeful that this will help.  

    https://community.blueprism.com/communities/community-home/digestviewer/viewthread?GroupId=97&MessageKey=7bac3522-efbf-4145-8250-0e55b63cc506&CommunityKey=3b501789-976c-4cfa-b9db-88307c6a0a86&tab=digestviewer&ReturnUrl=%2Fcommunities%2Fcommunity-home%2Fdigestviewer%3FMessageKey%3Dc1025ae8-2eff-4e65-bbbc-100e0c50e5d5%26CommunityKey%3D1b679a41-ef27-4557-a2dd-9af040812654

    There is a link in the reply that will take you to a BP support note with regards to this issue.

    ------------------------------
    Leslie Jones
    Configuration and Control Specialist, RPA
    Meridian Credit Union
    ------------------------------



  • 4.  RE: Spying in Chrome: Browser Mode not Working in different environments

    Posted 24 days ago
    I've had this issue as well. Seemed like the the version 2.1 of the extension had intermittent issues with BP 6.5, so I rolled back to extension version 2.0.1. The issue was that the extension eventually updates after Chrome launches. 

    This worked for us - uninstall Extension version 2.1 and reinstall 2.0.1. Then prevent the extension from updating automatically. Couldn't find a way in Chrome to do this, so we had to change permissions on the folder.

    C:\Users\<user>\AppData\Local\Google\Chrome\User Data\Default\Extensions\nadpbbdaaifbaebnniobcfpiifbfokij

    On the extension folder (nadpbbdaaifbaebnniobcfpiifbfokij) - go to Properties, Security, select the User Name, click Edit to change the permissions. Remove List Folder Contents and Write permissions. This stopped the extension from updating to the new automatically.



    ------------------------------
    Tom Maloney
    Architect
    nBotix, Inc.
    America/Chicago
    ------------------------------



  • 5.  RE: Spying in Chrome: Browser Mode not Working in different environments
    Best Answer

    Posted 24 days ago
    Hi James,

    Please go through the below link and download appropriate ext.

    https://bpdocs.blueprism.com/bp-6-8/en-us/Guides/chrome-firefox/browser-extension-install.htm?tocpath=Guides%7CChrome%2C%20Edge%2C%20and%20Firefox%20integration%7C_____1#Install4

    add "-force-renderer-accessibility" in the command line parameters of the application modeler If still issue is there.

    Thanks
    Nilesh

    ------------------------------
    Nilesh Jadhav
    Senior RPA Specialist
    ------------------------------