Blue Prism Product

Product_Community.jpg
Expand all | Collapse all

BluePrism version 6.8 backward compatibility

Jump to Best Answer
  • 1.  BluePrism version 6.8 backward compatibility

    Posted 08-11-2020 04:37
    Hello,
    we are moving from version 6.5 to 6.8 BluePrism. 
    My question would be: 
    Are new BluePrism release backwards compatible? We have running processes on PROD on version 6.5.
    Unfortunately I haven´t found any official announcement or documentation so far regards to this. 

    Thanks is advance,
    KJ

    ------------------------------
    Katarina Jakubcova
    ------------------------------


  • 2.  RE: BluePrism version 6.8 backward compatibility

    Posted 08-11-2020 09:35
    Hi Katarina.

    Yes BluePrism releases are backwards compatible. Having said that, it is important to review the release notes for anything specific. If you look at 6.8's release notes, you find a section on upgrading from previous versions (page 6) as well as a couple of comments on page 118 and 132).

    Here is the URL for the notes: https://portal.blueprism.com/system/files/documents/Blue%20Prism%20Release%20Notes%206.8.0_1.pdf

    You will have to log into the portal to access them.

    jack

    ------------------------------
    Jack Look
    Sr Product Consultant
    Blue Prism
    ------------------------------



  • 3.  RE: BluePrism version 6.8 backward compatibility
    Best Answer

    Posted 08-12-2020 04:40
    Jack is not quite correct. In principle BP releases should not be thought of a backwards compatible, although in practice they often are.

    Let's say you create a process that uses a feature introduced in the new BP version - if you import that process into an older BP, that version will not 'understand' the process content. The same would happen if you edit an existing process and introduce a new feature - if that process re-enters the old BP version, the new feature will not be compatible.

    However, if the process does not contain anything new, then it should be fine going back into an older version. I say 'should' because it is not guaranteed, and the larger the difference between the versions, the higher the chance of something not working if you go back.

    Understanding this is vital for creating a viable upgrade rollback strategy.

    ------------------------------
    John Carter
    Professional Services
    Blue Prism
    ------------------------------



  • 4.  RE: BluePrism version 6.8 backward compatibility

    Posted 08-12-2020 09:18
    Thank you for the clarification and education John.

    jack

    ------------------------------
    Jack Look
    Sr Product Consultant
    Blue Prism
    ------------------------------



  • 5.  RE: BluePrism version 6.8 backward compatibility

    Posted 08-12-2020 10:22
    Respectfully, backward compatibility is only about whether code written in an older version of a product will continue to run in a newer version without requiring any changes. To the original question, as a customer, we've been running BP since 5.3 and have gone through several upgrades without issue. But of course, only after full testing in our non-production environment.

    ------------------------------
    Leslie Zatony
    Tech Arch
    HSB
    America/New_York
    ------------------------------



  • 6.  RE: BluePrism version 6.8 backward compatibility

    Posted 08-12-2020 14:01
    OK maybe I've misunderstood the original question - apologies!

    Will a process created in a lower BP version work in a higher version? Yes

    Will a process created/edited in a higher BP version work in a lower version? Maybe. Probably yes if the version difference is minor, probably no if there is a big difference.

    ------------------------------
    John Carter
    Professional Services
    Blue Prism
    ------------------------------



  • 7.  RE: BluePrism version 6.8 backward compatibility

    Posted 08-16-2020 03:18
    Hi, Katarina,

    I do not know whether you got the answer you expected but let me give you some more information.

    BP version 6.5 and below are somewhat compatible when you create release you can run it in 6.4, 6.3, etc. (I do not know exactly how many versions backward it is compatible), however, when you upgrade to 6.6 there was a change in XML (Blue Prism internal format for storing business objects and processes) and there is no way going back any more. So upgrading from 6.5 to anything newer is more challenging. You should be more careful and do your testing first (well, you should do it always anyway). You should make a back up of your database before upgrading because once you migrate your environment to 6.6 or above there is no way back unless you stored your processes/objects in previous version.

    I hope it answered your question.

    Regards,

    ------------------------------
    Zdeněk Kabátek
    Head of Professional Services
    NEOOPS
    http://www.neoops.com/
    Europe/Prague
    ------------------------------