Blue Prism Product

last person joined: yesterday 

Chat about Blue Prism products
Expand all | Collapse all

Activate Application losing focus

  • 1.  Activate Application losing focus

    Posted 08-12-2020 09:33
    Edited by James Williams 08-12-2020 10:13
    ​Hi Community,

    We have recently had our system patched with the usual security updates and whatever else Microsoft had in store and since then we have been experiencing problems with IE within Control Room.

    The issue is that once IE is launched and we move on to another step such as opening Internet options or entering information like a login in the browser, IE seems to move out of focus and the process then hangs in control room.

    We have spied the IE window and have tried the following:

    1) In a Navigation stage "Activate Application" and then performed clicks, send keys, global mouse clicks, button presses with shortcuts, and extra waits.

    2) Split the Navigation action up e.g. "Activate Application" then a wait then a Mouse Click, Button Press or Send keys.

    Each time the application seems to phase into the background as if its not there even if we click the window or maximise. Then when we go to perform our next step e.g. to log into something its as if the IE window is not there and it hangs in control room.

    We've had this process running without issues for several years and its just started to go haywire after the patch, however nothing GUI wise has changed in IE. We have been through the application modeller and everything is still spied ok.

    Any help would be appreciated. We are using v6.6

    James Williams

  • 2.  RE: Activate Application losing focus

    Posted 08-13-2020 07:28
    Hi James,

    Please can you provide the versioning information in the 'About Internet Explorer' page and we may be able to better advise.

    Alternatively, this sounds like it may be worth logging a ticket via support as I am not aware of any issues caused by recent IE updates.


    John Pass
    Senior Customer Support Analyst
    Blue Prism

  • 3.  RE: Activate Application losing focus

    Posted 08-13-2020 07:33
    Hi John

    I have now resolved the issue it turned out the homepage that was launching was causing the issue.

    Once I changed the URL it worked fine.


    James Williams