Blue Prism Product

last person joined: yesterday 

Chat about Blue Prism products
Expand all | Collapse all

Issue with Chrome on VM and not my PC

  • 1.  Issue with Chrome on VM and not my PC

    Posted 08-06-2020 16:02
    Good afternoon, I have encountered a strange issue. I am working in 6.7.2. I built a process on pc that launches Chrome.exe. most of my spying is UIA, some in Browser mode. I log in to one of my VMs (same version of Chrome, the extension is the same too) Chrome will launch but the process cannot log in.  I check my spying and none of it worked. Now I cannot even spy anything in UIA only browser mode. I cannot go back through all my objects and re spy everything. 

    Has anyone ever seen anything like this? I ran BP as an administrator to see if that would correct this issue. No joy. I do not even get an exception with the process tries to log in to the system. I am meeting with my sysadmin team tomorrow (to see if there is something different about chrome on the VMs that I am missing) but I wanted to reach out to the BP community to see if any of you have heard of this type of issue before.

    Respectfully,

    Barry

    ------------------------------
    Barry Bell
    RPA Manager
    DHGLLP
    America/New_York
    ------------------------------


  • 2.  RE: Issue with Chrome on VM and not my PC

    Posted 08-06-2020 17:20
    Hi Barry,

    please check this article:
    https://portal.blueprism.com/customer-support/support-center#/path/Automation-Design/Application-Integration/Chrome/1319712802/Why-is-my-Process-no-longer-able-to-spy-or-interact-with-Chrome-Browser.htm

    Not sure if that's the reason of your problem but I would start from there. That behavior has been addressed and changed in v6.8.


    ------------------------------
    Luca Valente
    Senior Product Consultant
    Blue Prism
    America/New_York
    ------------------------------



  • 3.  RE: Issue with Chrome on VM and not my PC

    Posted 08-07-2020 09:04
    @Luca Valente Thanks for the article. I have forwarded this to my team to read before our call today with SysAdmin.​

    ------------------------------
    Barry Bell
    RPA Manager
    DHGLLP
    America/New_York
    ------------------------------



  • 4.  RE: Issue with Chrome on VM and not my PC

    Posted 08-07-2020 01:23
    Hi,

    In addition to trying what Luca has posted, could you also provide some more information on these points:
    • What remote access tool are you using to "log on" to the VMs? For example, VNC, RDP, etc.
    • What do you mean by Login?  Do you mean that you are using the Login Agent to login to the Windows account for the VM?  Or are you logging in to some application as part of the process automation?
    • When you say that your spying does not work, are you running it from the Control Room on the VM, or do you mean when you open the Object Studio on the VM through your remote desktop software, you are unable to spy?

    The reason why I ask is because RDP (and other remote access tools which use RDP as the underlying protocol) can cause spying exceptions to be thrown due to the way it handles user sessions.  If you are using an RDP-based tool to remotely login into the VM, we would suggest to change to a different tool.  The document here: https://portal.blueprism.com/documents/v6-data-sheet-remote-access-tools lists out some tools that other customers have had success with.

    ------------------------------
    James Man
    Professional Services
    Blue Prism
    Asia/Hong_Kong
    ------------------------------



  • 5.  RE: Issue with Chrome on VM and not my PC

    Posted 08-07-2020 09:02
    @James Man

    Answers to your questions:

    1. RDP
    2. logging in to some application as part of the process automation. 
    3. The control room on the VM,  Object Studio, and Process Studio (what I mean is that the previous s[ying is no longer valid, the element cannot be found and the element can no longer be detected with UIA. I used UIA in the original building of the objects because browser mode was not effective.  


    4. We tried to use Damware in the past but found it difficult to work in( Screen resolution and latency with using the mouse or typing) Our Firm no longer uses Bomgar. 
    we tried using the above because we had issues with screens locking up due to "inactivity" although a process was running.  Due to company policy, we cannot disable the screen savior so we installed "Caffeine" to keep the desktops active.

    We consulted the paper you mention above when we first ran into the issues on the screens locking up.



    Thanks for your help. ​

    ------------------------------
    Barry Bell
    RPA Manager
    DHGLLP
    America/New_York
    ------------------------------



  • 6.  RE: Issue with Chrome on VM and not my PC

    Posted 08-07-2020 13:57
    Edited by Barry Bell 08-07-2020 14:04
    Our issue has been resolved.  

    The fix for it was in the app modeler set up to use this in the url spot 
    oururl --force-renderer-accessibility Now when Blue Prism launches it, it uses the --force-renderer-accessibility




    ------------------------------
    Barry Bell
    RPA Manager
    DHGLLP
    America/New_York
    ------------------------------



Share