Blue Prism Product

last person joined: 30 minutes ago 

Chat about Blue Prism products
Expand all | Collapse all

Chrome Objects not found on Runtime Resources

  • 1.  Chrome Objects not found on Runtime Resources

    Posted 09-22-2020 09:46
    Hello,

    I am having issues with business objects that were created on the Chrome browser and work when in debug mode or run locally.  When I try to run the process on a runtime resource, it is unable to find the objects.  Would anyone have any suggestions as to why this issue is happening or what can be done?

    We are using BP version 6.5.1, Chrome browser is 85 and the BP extension is 2.1.0. Is it possibly due to an older version of Blue Prism?

    Any help would be greatly appreciated. 



    ------------------------------
    Leslie Jones
    Configuration and Control Specialist, RPA
    Meridian Credit Union
    ------------------------------


  • 2.  RE: Chrome Objects not found on Runtime Resources

    Posted 09-22-2020 21:06
    Hi Leslie,

    Please check the configuration of the "User Role" for the Blue Prism User and also the Business Object and the Runtime Resource Permission.


    ------------------------------
    Hossein Azimi
    Customer Support Engineer, APAC
    Blue Prism
    Sydney NSW
    ------------------------------



  • 3.  RE: Chrome Objects not found on Runtime Resources

    Posted 09-23-2020 07:50
    Thank you @Hossein Azimi

    I am not too sure how I would check the permission for the Business Object.  The application we are using is a single sign-on and there is no credential kept for the application.  That is the only place that I can think of to update user permission.  Would there be another place where permission would be stored?

    I am logging into ICD for my development then have a separate Dev Runtime Resource that is like Production.  The same process was built on IE and works with no issues on that browser.  ​

    ------------------------------
    Leslie Jones
    Configuration and Control Specialist, RPA
    Meridian Credit Union
    ------------------------------



  • 4.  RE: Chrome Objects not found on Runtime Resources

    Posted 09-23-2020 02:39
    Hi Leslie,

    When you switch from debug mode to runtime resource local, you need to take a restart of your computer. The same is the case when you want to go back to debug mode.


    ------------------------------
    Christer Tellefsen
    RPA Developer
    Frende
    Europe/Oslo
    ------------------------------