Blue Prism Product

Product_Community.jpg
Expand all | Collapse all

Global send keys not working on Windows application.

  • 1.  Global send keys not working on Windows application.

    Posted 08-10-2020 13:37
    Hi all,

    I am having problems using global send keys and global send keys events on a windows application.

    Blueprism only sends the first letter of the input to the selected field and shortcuts like ALT+O are not working.

    I cannot use the interval option because this is not available on my version (v5) and i already have tried the Activate/Focus solution mentioned in other threads.

    Anyone with this problem or a possible solution?

    Thank you!


  • 2.  RE: Global send keys not working on Windows application.

    Posted 08-10-2020 15:55
    Can you share a screenshot of your configuration to send the Global Send Keys? I know that I used this solution before:
    1. You have to spy an element on the page with AA spy mode.  This can be anything random.
    2. Then you have to change your Activate action to use this AA element as and action to Focus.  Then you have to add a second step of your Full Home Window element to Verify as shown in the pic below.  I also added a 1 sec pause between these steps:

    I would also minimize everything else on the screen so there is loss of the token or focus.

    ------------------------------
    Gabe Marquez
    Technical Support Engineer
    Blue Prism
    ------------------------------



  • 3.  RE: Global send keys not working on Windows application.

    Posted 08-11-2020 04:06
    Hi David - if the 1st character lands but the rest don;t then it sounds like a speed/focus issue. If you're still on v5 I'd recommend creating a page that mimics the interval feature of later versions. The page should take in a text parameter and send each character separately with a small interval (maybe 0.25s) in between, with things like ALT+O sent together. Slowing the keystrokes down, together with a small wait after an activate/focus/click, should work.

    ------------------------------
    John Carter
    Professional Services
    Blue Prism
    ------------------------------



  • 4.  RE: Global send keys not working on Windows application.

    Posted 08-11-2020 05:48
    Edited by David Cruz 08-11-2020 05:58
    I tried this and it is not working.

    I want to notice that my automation worked but after some time stop working. I do not know if this can be related with the resource. Did you know if anything related with the resource can be the root cause of this problem?

    Thank you

    ------------------------------
    David Cruz

    ------------------------------