Blue Prism Product

Product_Community.jpg
Expand all | Collapse all

Chrome plugin corrupted

  • 1.  Chrome plugin corrupted

    Posted 08-11-2020 08:43
    Hi,

    I am currently running into a problem when trying to run automations on Chrome, every time Chrome starts up the plugin won't load. When I check the extensions in the browser it displays the message: "This extension may be corrupted".

    I tried already to repair the BP install, disable the feature and install the extension manually, reinstall both BP and Chrome but nothing seems to work, the message keeps getting displayed.


    I am using BP version 6.8 and Chrome Version 81.0.4044.138 (Official Build) (64-bit).

    Any suggestions on how I could tackle this issue?

    Regards


    ------------------------------
    Lorenz
    ------------------------------


  • 2.  RE: Chrome plugin corrupted

    Posted 08-12-2020 11:37
    Thank you for your message, please try remove the extension from Chrome and download again using the Chrome Store to get the extension from another source.



    I hope this works for you.

    ------------------------------
    Luis Lopez
    Customer Support Engineer English and Spanish
    Blue Prism Ltd
    ------------------------------



  • 3.  RE: Chrome plugin corrupted

    Posted 08-13-2020 04:16
    Hi Luis,

    Tried that already plenty of times and that didn't fix the issue. In the end I noticed that the extension was always trying to load from the 2.0.0.1_0 folder instead of the 2.1.0_0 folder in the directory "AppData\Local\Google\Chrome\User Data\Default\Extensions\nadpbbdaaifbaebnniobcfpiifbfokij". I copied the files from the 2.1.0_0 folder into the 2.0.0.1_0 folder which makes the extension load uncorrupted in Chrome. However, now the extension will only work when the option "Use fixed extension port 31924" is enabled, which sometimes causes the extension to not work between 2 runs.

    For example: I run a process that uses Chrome and close the browser, on the next run of that process it does not recognise any elements in the browser untill the resource is restarted again. Both processes are run from the control room so I would think that using the setting Use fixed extension port would work in that situation.

    ------------------------------
    Lorenz
    ------------------------------