Digital Exchange Community

DX_Community_Banner.png
Expand all | Collapse all

Blueprism Isn't Returning Database Results

  • 1.  Blueprism Isn't Returning Database Results

    Posted 09-30-2019 12:01

    I have a Blueprism object which opens an Oracle database connection and runs a SQL script. This object has been working correctly for the past 12 months. I am developing a new process and the object isn't bringing back any results. If I run the SQL select against the database it returns results. When Blueprism runs it doesn't bring back any results. I am manually connecting as the same user account.

    I cannot provide SQL but it is a standard Select with where clauses. Stack Overflow is not allowing me to upload a photo of my object.

    --------------------------------------------------
    Disclaimer: This content was auto-posted from Stackoverflow. The original Stackoverflow question is here Stackoverflow Post, posted by E_McAndrew.


  • 2.  RE: Blueprism Isn't Returning Database Results

    Posted 11-19-2019 13:21
    Were you able to find a solution to this?
    Am facing the same issue

    ------------------------------
    Nupur Sood
    Research Associate
    S&P
    Asia/Kolkata
    ------------------------------



  • 3.  RE: Blueprism Isn't Returning Database Results

    Posted 11-20-2019 03:54
    Edited by Vivek Goel 11-20-2019 03:56
    Does it throw any error or just not returning results?
    I believe the issue to be with your query itself if it's not returning any results.

    I had a similar issue when the normal SQL worked fine in TOAD, but didn't work using blue prism. The issue was found to be with some date functions. 

    Cross and doublecheck your date functions and formats. Use Native formats like "dd/mm/yyyy" to get the results,

    ------------------------------
    Vivek Goel
    RPA Architect
    Asia/Singapore
    +6594554364
    https://www.rpatools.com/
    ------------------------------