Community Chat

last person joined: 4 hours ago 

Chat, tips, and news from the Blue Prism Community
Expand all | Collapse all

Problems with get files

  • 1.  Problems with get files

    Posted 11-18-2020 06:37
    Hi!
    
    I am having problems with file management. Get files.
    What is happening to me is that if I run the process manually, it brings me the files in the collection, but when I throw it in the control room, the process ends without doing anything.
    From what I was seeing, when it runs by itself, adding an action that counts the number of rows in the collection, it returns 0, that is, it doesn't bring any file and I don't understand why.
    
    I am using BP version 6.7.2
    
    Did someone have this problem?
    
    Thanks a lot!


    ------------------------------
    Sofia
    ------------------------------


  • 2.  RE: Problems with get files

    Posted 11-18-2020 09:46
    I'd ensure the files exist on the target machine, and check the Success and Message outputs from the Get Files action. If it has a problem retrieving the files (such as an authorization issue), it will let you know via those two outputs.

    ------------------------------
    Nicholas Zejdlik
    RPA Developer
    ------------------------------



  • 3.  RE: Problems with get files

    Posted 11-18-2020 09:53
    You may even get a better understanding of what's happening if you step through your process and into the Get Files action. Sometimes there's more info there than is shared with the process calling the action.

    ------------------------------
    Happy coding!
    Paul
    Sweden
    ------------------------------



  • 4.  RE: Problems with get files

    Posted 11-18-2020 10:02
    Hi Sofia

    As luck would have it I recently had this same issue and resolved it. Is this a shared folder/address? In my case I was mapping shared folders to a drive on the machine and this worked fine when accessing through the process manually. However when I run the process on its own through scheduler it returns 0 files or directory doesn't exist errors. I was set the path to the files/folders as it appears on the machine e.g. Y:\My shared folder\Business Folder\My File but when we run this in the scheduler we need to exclude the drive letter so it reads the explicit path which, in this case, would be \\My shared folder\Business Folder\My File

    Removing the drive letter resolved this for me so hopefully its a similar issue you are having and can resolve it the same way.

    Hope this helps :)


    ------------------------------
    Michael ONeil
    Technical Lead developer
    Everis Consultancy
    Europe/London
    ------------------------------



  • 5.  RE: Problems with get files

    Posted 11-23-2020 12:41
    Hi @Sofia,

    Have you received ans ?​

    ------------------------------
    Nilesh Jadhav
    Senior RPA Specialist
    ADP
    India
    ------------------------------



  • 6.  RE: Problems with get files

    Posted 11-24-2020 08:50
    Hi Sofia.

    In the input parameters of the Get Files action in CSV Patterns, place "*" test if it brings you the files from the path you passed in the folder.
    If it works for you manually unattended by the control room it should work.

    I hope I've helped !!

    Cheers

    ------------------------------
    Jhogel Ponne
    Senior RPA
    Ernst & Young
    America/Panama
    ------------------------------



  • 7.  RE: Problems with get files

    Posted 11-24-2020 09:51
    Hi Sofia, Check Michael ONeil 's Answer, If you are accessing the shared drive, the path  would be probably causing the issue. Instead of a drive mapping the folder, use "\\" to refer to the network drive,

    ------------------------------
    Vivek Goel
    Submit Your Built solution for "The" RPACULT 2020- The Unique RPA Hackathon of 2020.
    http://therpacult.com
    ------------------------------



Share