Product Updates

 View Only
last person joined: 27 days ago 


  • 1.  URGENT NOTIFICATION RELATED TO USE OF CHROME AND EDGE BROWSERS AS PART OF BLUE PRISM AUTOMATIONS

    Posted 05-13-2022 13:34

    Announcement from: 5-13-2022

    Google (Chrome) and Microsoft (Edge) have announced that they are changing the way third-party browser extensions are supported. On January 1, 2023, any browser extension that uses their Manifest V2 (MV2) standard will no longer operate.   

    In response to this announcement, Blue Prism has created a new browser extension that supports Manifest V3 (MV3).  

    Customers who currently use either of these browsers as part of their automations must upgrade to a version of Blue Prism software that offers MV3 support by the end of 2022 and test their automations as part of that upgrade process. 

    In addition, customers should be aware that with MV3, Google (and Microsoft) have removed the capability to perform JavaScript invocation or injection. Customers who utilize that capability must modify their automations to overcome the vendor-imposed restrictions. 

    To help our community of users identify if they are impacted by this announcement - our product team has provided a utility that will determine if you are affected by this issue. We recommend that you run this utility, which can be found here https://digitalexchange.blueprism.com/dx/entry/3439/solution/manifest-v3-impact-assessment-utility

    If the utility identifies you are affected (i.e., Using Chrome or Edge / utilizing the JavaScript insert/invoke function) please make sure your organization completes the survey sent to them by their account or customer success manager.

    Note: this survey is intended for end-users of Blue Prism only. If you haven't received this survey and feel that you should have, please contact your Blue Prism representative. Information for Blue Prism partners is available on the Connect Partner Portal.


    Our upcoming releases (7.1 and 6.10.5) will contain Browser Extension support for Manifest V3.
     

    [Note: these versions will also support those customers who could not apply the January 2022 Microsoft security patch update. Visit FAQs. http://portal.blueprism.com/customer-support/support-center#/path/-Featured-Articles/1784860762/-Solution-Windows-updates-from-11th-January-2022-causing-authentication-issues-in-Blue-Prism.htm] 

     

    Our communication regarding this event will evolve in the coming weeks and months. In the meanwhile, please find the latest information in our Knowledge Base FAQs. https://portal.blueprism.com/customer-support/support-center#/path/Alerts/1831250872/URGENT-NOTIFICATION-RELATED-TO-USE-OF-CHROME-AND-EDGE-BROWSERS-AS-PART-OF-BLUE-PRISM-AUTOMATIONS-ACTION-REQUIRED.htm



    ------------------------------
    Charlotte Kennett
    Director, Global Customer Marketing & Community
    Blue Prism
    Europe/London
    ------------------------------


  • 2.  RE: URGENT NOTIFICATION RELATED TO USE OF CHROME AND EDGE BROWSERS AS PART OF BLUE PRISM AUTOMATIONS

    Posted 07-18-2022 19:02
    HI,

    Was MV3 included in the latest v7.1 release?
    The release notes are not very clear about it


    Thanks,
    Miguel

    ------------------------------
    Miguel Jesus Fernandez Lopez
    Director of Intelligent Automation
    INVOKEinc
    ------------------------------



  • 3.  RE: URGENT NOTIFICATION RELATED TO USE OF CHROME AND EDGE BROWSERS AS PART OF BLUE PRISM AUTOMATIONS

    Posted 07-20-2022 09:20
    Hi, Miguel,

    As far as I understood, the BP 7.1 is supporting both versions of Manifestos - MV2 and MV3 in general. But the key here is that when Microsoft publishes an update in the Edge (around 2023/01 preliminary), the MV2 won't be supported by browser, which result in stopping automation where JavaScript invokes and injects are used.

    @Charlotte Kennett - Is that correct?​

    ------------------------------
    Lukas Ramasauskas
    RPA Software Engineer
    Swedbank AB
    Europe/Vilnius
    ------------------------------



  • 4.  RE: URGENT NOTIFICATION RELATED TO USE OF CHROME AND EDGE BROWSERS AS PART OF BLUE PRISM AUTOMATIONS

    Posted 07-20-2022 13:41

    Hello @Lukas Ramasauskas

     

    Blue Prism 7.1 only provides support for Manifest V3 (MV3) for Google Chrome and Microsoft Edge and does not also include a compatible MV2 extensions (for Chrome and Edge).

     

    It's the use of MV3 extensions that prevents JavaScript, not a date.

    I.e. Use Blue Prism 7.1 with MV3 extension today = no use of JavaScript invoke / insert.

     

    Tip: We're continuing to add to the Knowledge Base FAQs as we get new questions and learn new things.


    Kind regards
    Chris Strong
    Blue Prism Product Manage

    ------------------------------
    Chris Strong
    Product Manager
    Blue Prism
    ------------------------------



  • 5.  RE: URGENT NOTIFICATION RELATED TO USE OF CHROME AND EDGE BROWSERS AS PART OF BLUE PRISM AUTOMATIONS

    Posted 07-20-2022 13:39
    Hello Miguel Jesus Fernandez Lopez

    Yes – Manifest V3 (MV3) extensions for Google Chrome and Microsoft Edge were included alongside Blue Prism 7.1.

    Kind regards
    Chris Strong
    Blue Prism Product Manager



    ------------------------------
    Chris Strong
    Product Manager
    Blue Prism
    ------------------------------



  • 6.  RE: URGENT NOTIFICATION RELATED TO USE OF CHROME AND EDGE BROWSERS AS PART OF BLUE PRISM AUTOMATIONS

    Posted 09-06-2022 14:55
    Hello, it's been sometime since I checked on this but has an MV3 extension been released for Blue Prism version 7.0.1 ?  If not, is there an estimated release date?

    Thanks!

    ------------------------------
    Rafael Romero
    ------------------------------