Topic Thread

Expand all | Collapse all

Loop not accepting collection selected

  • 1.  Loop not accepting collection selected

    Posted 02-16-2018 15:46
    I am having trouble getting a loop to work with a collection. I have selected the collection on the drop down list under 'loop start' but when I then go back into it the collection has been de-selected immediately. Does anyone know why this would be?


  • 2.  I'm not sure what you mean…

    Posted 02-16-2018 18:02
    I'm not sure what you mean by ""go back into it the collection has been de-selected immediately?"" - it might be worth revisiting the foundation training exercises on looping collections.  To go back into a collection on the current row of that collection you do not go to the start or end stage you go just continue your flow between the two, to restart your loop from row 1 you go to the loop start, to go to the next row you go to loop end.  Exactly what are you seeing that differs from this functionality.


  • 3.  RE: I'm not sure what you mean…

    Posted 05-16-2020 19:29
    I am experiencing the same issue.  In the Loop Properties of Loop Start stage, I would select a collection to loop.  When I run that process, I would get an error message: "Internal: Invalid Collection supplied for each loop."  I realized that the assigned collection was deselected and that is the reason for the error message.  I don't understand why the collection gets deselected after it's been assigned.

    ------------------------------
    Sunshine Singh
    ------------------------------