Topic Thread

Expand all | Collapse all

Extended Run Time- Bot Terminating

  • 1.  Extended Run Time- Bot Terminating

    Posted 06-15-2020 15:13
    ​We have a process that runs for 4-5 hours using only two systems; excel and Credit Stream. This process is consistently terminating but not at the same function or timing. When it terminates, we are unable to recover easily and have to manually recreated all of our processed docs. None of our other processes are doing this but all of our other processes run for less than 30 minutes. We are having difficulty determining if this is the bot's VDI or if it is an application issue. We are going to scheduling a 'dummy' process to run for 4 hours using two other apps to see if this can help figure out the root issue. However, we have noticed that the bot will randomly go 'idle' in the middle of processing just for a couple of seconds.

    While we are working on troubleshooting this, I was curious if anyone else has experienced a similar issue with a process that runs for an extended period of time. Any tips or advice on how to work with processes that need to run longer than an hour? Any experience with a bot going idle in the middle of processing?

    ------------------------------
    Amanda Thompson
    ------------------------------


  • 2.  RE: Extended Run Time- Bot Terminating

    Posted 06-16-2020 11:07
    This can be caused by the Runtime's policies, such as power saving settings, machine idle settings etc.  It may also be caused by using RDP, if RDP is being used to remotely view the Runtimes while they are running a process.  Is there any exception messages that you are having that you can share?

    ------------------------------
    James Man
    Professional Services
    Blue Prism
    Asia/Hong_Kong
    ------------------------------



  • 3.  RE: Extended Run Time- Bot Terminating

    Posted 06-16-2020 16:34
    Thank you James- we ran a test process in prod last night for 4 hours. This process used two other systems, excel and notepad. The process ran successfully and did not terminate. Do you think with this information that it is the application not staying active?

    Below is a screenshot of the error.

    ------------------------------
    Amanda Thompson
    ------------------------------