Control Room & Scheduler

Expand all | Collapse all

Login Agent issue after update

  • 1.  Login Agent issue after update

    Posted 05-15-2019 18:22
    Recently I've started updating our installation of BP, going from version 5.0.33 to 6.4.2. The installation's worked out fine in our test environment, no issues at the server, DB, workflows or clients.   However, on the resources the login agent now, out of the blue, refuses to log in anymore. Throwing out ERROR:  : : The operation has timed out. in the Log In stage. There were no issues before the update and the policy settings haven't been changed.   The login agent is running, as the key is being shown in the controlroom, and it does recieve and start the login action. The logout command also works just fine. I've already looked around the forums for similar issues and couldn't really get further with those. I've tried restarting the app server and nodes, to no avail. We don't use RDP for the resources, the only way to adres them is vSphere (which we're still doing for our production resource on 5.0.33 without issue) And I'd have to rule out policy issues as those haven't been changed (I checked) and they worked before the update.   Using the guides and forum posts available I've now run out of ideas where the issue's at. Has anyone else had this issue or a potentially an idea where it's going wrong?


  • 2.  Hi, Maarten,   assuming you…

    Posted 05-15-2019 21:08
    Hi, Maarten,   assuming you see runtime resources with Login Agent icon on it waiting to get unlocked, right? Then you run Login process and it fails with the above message. Are you sure that you have the right Login Agent version installed? When you upgrade Blue Prism you should also update the Login Agent. It is part of the Blue Prism directory in Install subdirectory.  


  • 3.  Hi Zdenek,   I've removed…

    Posted 05-16-2019 13:09
    Hi Zdenek,   I've removed the old login agent installation and reinstalled it using the installer provided in the install directory.


  • 4.  Maarten - check the event…

    Posted 05-16-2019 14:41
    Maarten - check the event logs on the resource machine and the app server, there may be more clues there.


  • 5.  RE: Maarten - check the event…

    Posted 08-29-2019 11:44
    Hi,

    We have started to have similar issues from time to time. 'Login VM' fails on 'Log In' Stage on main page with same "
    ERROR:  : : The operation has timed out.
    "
    i could not find any clues in Events, neither on VM or Server itself.
    We use BP 6.2 with LoginAgent from it; We look forward to upgrade to 6.5 soon.

    Restarting VM is not an option at this point.

    ------------------------------
    Lukas Ramasauskas
    RPA Software Engineer
    Swedbank AB
    Europe/Vilnius
    ------------------------------



  • 6.  I've now checked the…

    Posted 05-22-2019 15:21
    I've now checked the eventlogs: On the app server there is no mention of the attempt in the event logging. On the resource I find "Session (ID:.......) terminated. Process Name: Login; Reason::: The operation has timed out.   Sadly no more specific information.


  • 7.  I've found the issue. I've…

    Posted 05-28-2019 20:28
    I've found the issue. I've tried installing the 64-bit version instead of 32-bit, now it does work.


  • 8.  RE: I've found the issue. I've…

    Posted 08-29-2019 15:42
    Also import the latest Loginagent BP release when ever you update the login agent version. else the process will show as completed but machine will still be logged out

    ------------------------------
    Jerin Jose
    RPA Product SME
    EY
    Asia/Kolkata
    ------------------------------