Control Room & Scheduler

Expand all | Collapse all

Login Agent Not working

  • 1.  Login Agent Not working

    Posted 02-18-2019 21:29
    I had a PC on which login agent was running successfully. Suddenly out of the blue scheduling the Login of the login agent does not work. Get the error "Task: Login threw an exception:Resource Pc11111: Timed out waiting for valid connection". I  looked over security policy and the login agent credentials etc and they all seem fine. When I look at the control room on another PC the PC is seem ready and waiting for the connection call with the key icon. The runtime resource comes up when I logon to the remote PC. I am able to run login on the said PC manually just not able to schedule it. Can anyone offer any trouble shooting ideas to pursue.


  • 2.  Restart server. If you use…

    Posted 02-18-2019 22:48
    Restart server. If you use more than 1 node, you can see which node is not work in the message. 


  • 3.  We have the same problem,…

    Posted 02-19-2019 04:01
    We have the same problem, the advice I have gotten is: 1. Make sure you are on the current version and update if necessary (6.4.1) 2. Restart the app server and then restart each run time resource 3. Then to restart the app server when this happens again or once a week. Not a big fan of number three but it seems to be required.  


  • 4.  Restarting the app server…

    Posted 03-06-2019 00:36
    Restarting the app server and the resource pc seemed to do the trick. Thanks all


  • 5.  RE: Restarting the app server…

    Posted 09-19-2019 13:38
    I am facing the same issue
    "timed out waiting for valid connection "
    In my case,I have everything in a single server, Including Application serer & Resources.Also developed the BOT in the same server.

    Restarted the server but did not work.

    Please advice.


    ------------------------------
    Sumanth B
    Developer
    Cognizant
    ------------------------------



  • 6.  RE: Restarting the app server…

    Posted 09-19-2019 14:06
    ​Hope you have the Blueprism server service configured and running properly. since you have everything configured on same machine you might forgot to run a public runtime resource.
    Scheduler will look for Public runtime resource.it will not trigger process to the private connection. start a public runtime and see if the scheduler is able to fire. to avaoid conflict start the listener on a different port other than port 8181 and assign the task to run on the resource pc listerning on that port (eg:port 8182)

    "C:\Program Files\Blue Prism Limited\Blue Prism Automate\Automate.exe" /resourcepc /public /port 8182

    ------------------------------
    Jerin Jose
    RPA Product SME
    EY
    Asia/Kolkata
    ------------------------------



  • 7.  RE: Restarting the app server…

    Posted 09-19-2019 16:11
    Thank you .
    It worked now.

    I am facing below issue now
    "could not identify process owning the current foreground window".

    I have connected through RDP and scheduled the Job, However, I have disconnected the server and assuming that it would run it.

    I saw some of the posts that RDP is not supported by BluePrism. Will it work with Radmin Viewer? 

    Also,  our servers are VM boxes and refreshes ad close all of the applications.

    Can you confirm whether the control room Bots run in background or it should require to open BP Control Room.


    ------------------------------
    Sumanth B
    Developer

    ------------------------------