Topic Thread

Expand all | Collapse all

ERROR: Internal : Execution Timeout Expired

  • 1.  ERROR: Internal : Execution Timeout Expired

    Posted 02-28-2019 19:12
    Recently we started getting exceptions whenever we have a large volume of concurrent robots running and that ends the process with the following exception: ERROR: Internal : Execution Timeout Expired.  The timeout period elapsed prior to completion of the operation or the server is not responding We get the same error (as a popup) from our client side too whenever it is happening for the processes. According to BluePrism support it is because of the 'BPASessionLog_NonUnicode' table that grew too much in size (around 50+ GB) and there also was a DB maintenance PDF that I got from the Documents section. According to the DBA all of the best practices were being followed and we trimmed the table down to 8 GB now. I am still seeing those erorrs. We are trying to reduce the logging throughout all of our processes in Prod (to errors only and only on the stages necessary) but that will take some time. We also toyed around with the logging  options in the process settings but that did not help. I know that there is a setting on the resource level that can turned down to 'log only on errors' type of setting but before that I wanted to see if anyone out there experienced the same and somehow got it resolved? I would really appreciate any feedback pointing me in the right direction. Thanks, Atif Abbas.


  • 2.  It happened once for us as…

    Posted 03-14-2019 19:34
    It happened once for us as well. To resolve this issue we did two things. Increasing the size of memory and by disabling the logging.  


  • 3.  By increasing the size of…

    Posted 03-15-2019 01:08
    By increasing the size of memory do you mean to increase the memory on runtime resource or the database side.


  • 4.  RE: ERROR: Internal : Execution Timeout Expired

    Posted 10-25-2019 17:43
    Did you solve this problem? I have the same error, we trimmed the table "BPASessionLog_NonUnicode" down to 10 GB and we did  an archive but still is throwing an error when I use the stage "GET NEXT ITEM". Thanks.

    ------------------------------
    Oscar Celio Avila Castellanos
    Ingeniero de sistemas
    VASS LATAM
    ------------------------------