Control Room & Scheduler

Expand all | Collapse all

Runtime Resource is perceived offline by BP app server when starting up after Azure VMs have been deallocated

  • 1.  Runtime Resource is perceived offline by BP app server when starting up after Azure VMs have been deallocated

    Posted 02-25-2020 12:01
    Hi community,

    Our Blue Prism environment is hosted in Azure Cloud. Recently we have implemented Azure's start stop functionality where the VM's are deallocated (with static IP's though) at night to save costs. Since our environment has to start-up each morning we have been running into stability issues. I have not been able to pinpoint the exact cause.

    It seems that the BluePrism Server Service on the application server starts-up fine. However, it is not able to connect with the Runtime Resource. As a first try we have chosen to start the runtime resource VM half an hour later to not mess with the sequence of connection. This did not have any effect. So when the schedule tries to login, it states that the resource is offline whereas it is in fact started. So I guess it has something to do with the Runtime Resource Service..

    Do any of you have experience with start-stop of the environment and ran into similar issues?

    Best,
    Nanne

    ------------------------------
    Nanne van der Wal
    Advisor
    EY
    Europe/Amsterdam
    ------------------------------


  • 2.  RE: Runtime Resource is perceived offline by BP app server when starting up after Azure VMs have been deallocated

    Posted 02-27-2020 10:04
    We are also going through the same issue. 

    Can you try updating the host file with relevant host names as IP addresses ( had quick win there), not sure how sustainable it would be.

    Regards,
    Kartik

    ------------------------------
    Karthick Sivabalasubramaniam
    Technical Lead
    Wipro
    Asia/Kolkata
    ------------------------------