Application Integration

Expand all | Collapse all

Cannot identify the Java application

  • 1.  Cannot identify the Java application

    Posted 08-08-2017 08:43
    Hi All, I would like to automate process which using the "Murex" (Java based application) . When I started the application thru the Application Modeler button 'Launch' application is started, but button doesn't change to 'Identify'. So I cannot start to Spying the App at all. Java Access Bridge is enabled. and I browsed "murex.exe" because there are thousand of .jar files. In addition, I€™m using BP version 5.0.23. Thank you for any advice. Kota


  • 2.  Hi

    Posted 08-08-2017 12:01
    Hi Have you checked these materials? https://blueprism.knowledgeowl.com/help/how-to-interact-with-java-appli… https://portal.blueprism.com/system/files/product/productpublic/5.0/Inf… https://portal.blueprism.com/system/files/Java%20Automation%20Guide.pdf Hope this helps.


  • 3.  >tjunicho

    Posted 08-14-2017 17:58
    >tjunicho Hi. It was really helpful. Thank you for sharing adequate materials. Best regards, Kota


  • 4.  >tjunicho

    Posted 08-14-2017 17:59
    >tjunicho Hi. It was really helpful. Thank you for sharing adequate materials. Best regards, Kota


  • 5.  Besides enabling JAB in

    Posted 08-08-2017 13:42
    Besides enabling JAB in config, try also copying accessibility.properties file from java install path (i.e. c:\program files (x86)\Java\jre7\lib) to your user home folder (i.e. c:\users\username), open and uncomment (delete #) two last lines. I noticed that sometimes applications does not respect the settings from java console, but they do using that file. More into about file structure: http://docs.oracle.com/javase/7/docs/technotes/guides/access/properties…


  • 6.  >Miq

    Posted 08-14-2017 18:02
    >Miq Hi.Thank you for reply. I finnaly solve the problem with your suggestion. I really apperciate for your adequate answer and reply. Best regards, Kota


  • 7.  Hi Kota,

    Posted 10-26-2017 23:59
    Hi Kota, I am in the same situation as you were. I'm trying to spy Murex, a Java based appl'n without any success. Able to launch, Identify but unable to spy in Java mode. Enabled JAB and did the rest what is required as mentioned in the documents. I would like to reach out to you to discuss and understand on the trouble shooting part. Would you mind passing me your contact details. Thanks! Kiran


  • 8.  Hi Miq,

    Posted 10-27-2017 02:56
    Hi Miq, I tried implementing your thought as well. Nothing is working for me. Any advice would be greatly appreciated! Kiran


  • 9.  You welcome.

    Posted 08-28-2017 15:01
    You welcome. @Blue Prism - could you include this workaround in Java Automation Guide?


  • 10.  Hi,

    Posted 09-12-2017 13:32
    Hi, I have configured the java access bridge, is able track the mouse events of my java application on JavaFerret and also is able to view the tree of elements on the JavaMonkey after the JAB installation. But, somehow I'm still not able to identify my java application elements using blueprism nor able to find the elements on application navigator of accessibility. I'm using BP 5.0.30 Please advise. Thanks in advance


  • 11.  I was able to identify the…

    Posted 04-04-2019 02:56
    I was able to identify the application but I have problems identifying the grids... any idea?   Regards.


  • 12.  RE: I was able to identify the…

    Posted 11-21-2019 18:42
    Hi Esteban,

    Did you find the solution for your issue? i have the exact same situation. please let me know how you resolved it. It would be really helpful.

    ------------------------------
    Manjunath N
    Analyst
    capgemini
    Asia/Kolkata
    ------------------------------