Topic Thread

Expand all | Collapse all

Problem with integrating Blue prism and IBM watson NLU services.

  • 1.  Problem with integrating Blue prism and IBM watson NLU services.

    Posted 10-13-2018 15:52
    Hi, I am trying to integrate BP with IBM Watson NLU. I followed the documentation provided by Blue prism the integration works well without changing .bp release file. To make the NLU specialize in domain I created a Watson knowledge studio and deployed to NLU service. The deployment is successful. In BP to check the successful deployment, I used €˜List models€™ object to get the models deployed in NLU. It gave the expected model id. But when I tried to invoke the BP object €˜Get Entities€™ object with the model id received from €˜List model€™ object it returns the error response . Error 400 invalid request. To check the validity of model id I used Watson API explorer, the Call to NLU with custom model id, it returned the expect entities. I am not sure why the http request with €˜Get Entities€™ object is failing with a Model ID parameter. Has anyone from BP tested the object with model id parameter ? We are looking for a large scale AI project with BP and IBM Watson, making this work will be a good POC for client that BP works well with Watson Intelligent services. Any help would be greatly appreciated Attached the document from BP about the integration. I will send more snapshot of errors if required. Thanks


  • 2.  RE: Problem with integrating Blue prism and IBM watson NLU services.

    Posted 11-11-2019 20:05
    Hi, did you ever have any luck with solving this issue?

    ------------------------------
    Sharyn Catt
    ------------------------------