Application Integration

Expand all | Collapse all

Outlook VBO - Email Encryption

  • 1.  Outlook VBO - Email Encryption

    Posted 10-14-2019 17:52

    Hello everyone,

    I'm currently facing an issue concerning the encryption of the emails sent by our robots and would like to know if anybody in the community has faced anything similar.

    For a bit of context, as a new policy, we must encrypt every email coming out of our runtime resources and I'm a bit lost about how to proceed. We are currently using Outlook from Office 365 and we would like to make use of the MS Outlook VBO to make our processes as efficient as possible. 

    We do have a solution where we would use the Application Modeller to connect to the Outlook UI and send our emails that way (since the encryption option is easily available in one of the menus) , but we are a bit concerned about the efficiency of it all.

    Feel free to ask for additional information if that can give you a brighter picture of the situation.

    Regards,
    Alex



    ------------------------------
    Alex Gosselin-Pronovost
    RPA Developper
    America/Montreal
    ------------------------------


  • 2.  RE: Outlook VBO - Email Encryption

    Posted 10-15-2019 14:24
    Well if you have a plugin in the MS Outlook that is handling the encryption for you automatically should do the decrypt in the same way, so whenever you do with the robot is encrypt/decrypt automatically. At least should be...

    ------------------------------
    Cohen
    RPA Developer

    Romania
    ------------------------------



  • 3.  RE: Outlook VBO - Email Encryption

    Posted 10-16-2019 15:34
    Hi Ionut,

    The issue is that it is not doing it automatically. Right now, you need to manually select an option to encrypt a specific email before sending it. We're trying to accomplish that via a VBO without having to use the application modeler.

    Thanks,
    Alex

    ------------------------------
    Alex Gosselin-Pronovost
    RPA Developper
    CGI
    America/Toronto
    ------------------------------



  • 4.  RE: Outlook VBO - Email Encryption

    Posted 20 days ago
    Hi Alex,

    I have similar issue with encrypted emails. We are using the Citrix addon in outlook to send out emails encrypted. I have defaulted to send all the email as encrypted for our runtime resource, but when I try to send an email manually from outlook it is sent as encrypted whereas when the email is send using MSOutlook VBO, it is not encrypted. 

    Any ideas?

    Any help will be greatly appreciated.

    Thank you.

    Regards,
    Swetha

    ------------------------------
    Swetha Devaram
    RPA Developer
    Health Markets
    America/Chicago
    ------------------------------