cancel
Showing results for 
Search instead for 
Did you mean: 

Utility HTTP- 400 Error message

KrishnaElapavul
Level 6

Hi 

I am using BP 7.1 and Utility HTTP ver 10.

Using POST method to send data in Json format.

when   HTTP - 400 error  occurs , I am not getting complete error message, I get just as below 

"The remote server returned an error: (400) Bad Request"

But when i post the same Json in Postman I get  the detail message

How to get  detail message through Utility - HTTP VBO? any idea please 

Thanks

Krishna



------------------------------
Krishna Elapavuluri RPA Solution Lead
TEchnology Consultant
DXC.technology
Asia/Kolkata
------------------------------
7 REPLIES 7

Hi Krishna, 

This solution helped in my case.

https://community.blueprism.com/question/http-utility-vbo-doesnt-return-json-when-status-code-is-400#e5544172-6088-47e9-af6f-018c7d90dce3

Raghav



------------------------------
Raghavulu Patchipulusu
------------------------------

Thanks Raghavulu

 

I tried this option but I am getting the message in non-readable format as shown in below  screen. Please note that if I send the same data in POSTMAN I get message in readable format .

 

15340.png

 

Thanks

Krishna

RPA – Solution Architect

OEA - Operations

SKF

DXC Technology

15341.png

T +91 99000 63042
Krishna-mohan.elapavuluri@dxc.com

DXC.com | Twitter* | Facebook* | LinkedIn* | Campaign Promotion*

 

Planned Leave: 

Company Holidays:26th Jan 2024

 

 



Hi Krishna,

Did you comment out the existing code resultData = e.Message: before placing the new code snippet? 

After that check for http status 400 and use JSON to collection object for getting the error message (incase if your HTTP post request returns JSON)

Raghav



------------------------------
Raghavulu Patchipulusu
------------------------------

Yes Commented Ragava

 

I get xml format data as response from downstream application.

 

 

Thanks

Krishna

RPA – Solution Architect

OEA - Operations

SKF

DXC Technology

15346.png

T +91 99000 63042
Krishna-mohan.elapavuluri@dxc.com

DXC.com | Twitter* | Facebook* | LinkedIn* | Campaign Promotion*

 

Planned Leave: 

Company Holidays:26th Jan 2024

 

 



Is your HTTP POST request returns XML data as response stream?



------------------------------
Raghavulu Patchipulusu
------------------------------

Yes Raghava

I POST in json format to SAP , SAP will send respond in xml . same will be used to enrich to fetch require data .

In POST man I get response data in readable format , but when I post through BP action I am getting this junk characters

 

 

 

Thanks

Krishna

RPA – Solution Architect

OEA - Operations

SKF

DXC Technology

15360.png

T +91 99000 63042
Krishna-mohan.elapavuluri@dxc.com

DXC.com | Twitter* | Facebook* | LinkedIn* | Campaign Promotion*

 

Planned Leave: 

Company Holidays:26th Jan 2024

 

 



LeonardoSQueiroz
Level 10
Hello,
 
Apparently there is an error in the call parameters.
 
Since the message is generic, check this thread: https://community.blueprism.com/question/http-utility-vbo-doesnt-return-json-when-status-code-is-400 How can you get more details from the error return.
 
Regards,


------------------------------
Leonardo Soares
RPA Developer Tech Leader
Bridge Consulting
América/Brazil
------------------------------
Leonardo Soares RPA Developer América/Brazil