Community Chat

 View Only
last person joined: 2 days ago 

A space for discussion around the Community site and programs.

  • 1.  Content length issues with the BP VBO Utility.HTTP

    Posted 17 days ago

    Hi, I am having some issues with the Utility HTTP VBO.

    Using the action "HTTP REQUEST" with the following inputs:

    The response seems to be missing some of the token data as it only returns 1590 characters:
    Here is the exact same request done in Postman, returning the complete token:
    Does the VBO have a max content length ? Any ideas or suggestions greatly appreciated.


    ------------------------------
    Gisle Bjøru
    ------------------------------


  • 2.  RE: Content length issues with the BP VBO Utility.HTTP

    Posted 14 days ago

    Hi @Gisle Bjøru,

    No, there are no content length restrictions within the VBO itself. Are you using the latest version of the VBO available from the Digital Exchange? I can tell you that there are occasionally differences between BP and Postman due to differences in how the two create their initial requests (mostly around headers though).

    Cheers,

    Cheers,



    ------------------------------
    Eric Wilson
    Director, Integrations and Enablement
    Blue Prism Digital Exchange
    ------------------------------



  • 3.  RE: Content length issues with the BP VBO Utility.HTTP

    Posted 13 days ago

    Hi Gisle Bjøru,

    I already checked this in an automation that carried out extensive queries, this variation at the time was due to the difference between the formatting of the dataitem x postman, but the result remained the same, try writing the output value in a txt to validate with Postman.

    Regards



    ------------------------------
    Leonardo Soares
    RPA Developer Tech Leader
    Bridge Consulting
    América/Brazil
    ------------------------------



  • 4.  RE: Content length issues with the BP VBO Utility.HTTP

    Posted 8 days ago

    Hi, thank you for the replies.

    It turned out that I had forgotten to pass the scope in the body of the request.

    adding "&scope=scope-name" solved it.

    Wasn't expecting the API to return a token if the input wasn't complete so this was confusing to say the least :)



    ------------------------------
    Gisle Bjøru
    ------------------------------



Welcome to our 'Off-Topic' Community Chat!

A space for non-technical chat, tips for using the Community, and news from the Blue Prism Community Team.

This is not a Community for technical or Product related discussion. For a list of available communities, please visit our site map.

Introduce YourselfCommunity Tech TipsMeet The Team