Community Chat

 View Only
last person joined: yesterday 

A space for discussion around the Community site and programs.

Expand all | Collapse all

UIA Spy method not working

  • 1.  UIA Spy method not working

    Posted 9 days ago

    Good Day team, Trust you are all well.

    We, all of a sudden on a particular BPC VM have started to experience elements that can no longer be found on an MS Edge browser process. We have used multiple spy methods, like Browser mode and UIA mode.

    For some reason all the UIA mode elements are throwing this error.

    This is an existing process been running for over a year and this error just started this last Sunday.

    When trying to re-spy the elements the UIA mode is only giving us the outer window element.

    Has anyone else experienced this and if so, are there any recommendations?

    Kind regards


    Gavin Rudling
    Digital Consultant & Developer

  • 2.  RE: UIA Spy method not working

    Posted 9 days ago

    I am unsure what widows you are using, but do you check this KB Article "How do I fix a UIA mode spying issue on Windows Server 2019?"

    Luis Lopez
    Customer Support Engineer English and Spanish
    Blue Prism Ltd

  • 3.  RE: UIA Spy method not working

    Posted 9 days ago

    Hi Gavin Rudling,

    I have issues in the past in some cases if I add "--force-renderer-accessibility" after the URL while launching the application it resolved it.

    But found this knowledge base article try this and please let me know how it goes.

    If I answered your query. Please mark it as the "Best Answer"

    Harish Mogulluri
    Lead developer
    America/New_York TX

  • 4.  RE: UIA Spy method not working

    Posted 15 hours ago

    Oh man have I scratched my head on this one - thanks a lot for the tip on "=complete" command!!

    For those interested you can see the difference with the "edge://accessibility" url command. 

    Christian Jørgensen
    Solution Architect Robotic Process Automation
    Yara International ASA

  • 5.  RE: UIA Spy method not working

    Posted 13 hours ago

    Hi Christian


    Yes, some of us are still scratching heads. In some cases, we have had to put in some retry logic around the launch because the =complete still had no effect on the outcome.

    We have seen cases where it fails the first time round but after throwing an exception and retrying, we seem to be able to move on.


    Kind regards



  • 6.  RE: UIA Spy method not working

    Posted 8 days ago

    Hi Gavin

    Did your VMs update Edge browser to v117.0.2045.31 on Sunday? If so:

    The latest versions of the following browsers are causing Accessibility/UIA spying to fail within Blue Prism Enterprise:

    ·         Google Chrome Version 117.0.5938.63 - released 13-Sept-23

    ·         Microsoft Edge Version 117.0.2045.31 - released 15-Sept-23


    This issue occurs because these latest browser updates have changed the default behaviour of the --force-renderer-accessibility flag (which enables UIA mode to spy on the browser elements). As a result, 'Complete' is no longer part of the force-renderer-accessibility command by default. 


    How to work around this issue

    Pass in the command "-force-renderer-accessibility=complete", which should resolve the issue and allow for UIA spying.


    If some of your automations have started not working (properly) this may well be the cause

    This was gleaned from BP support by @Ian Meldrum

    I had an automation failing that was using the old version of the --force-render-accessibility parameter and it started working again by removing that from the launch url

    Not tried the above solution yet myself



    Kirk Russell Senior Robotics Developer
    NHS Dorset

  • 7.  RE: UIA Spy method not working

    Posted 8 days ago

    Hi Kirk, Yes, I believe so.


    I got the same response from BPC support.


    Thank you for sharing, I have not tried the fix yet myself. I have only just got the solution now.


    Thank you kindly for your assistance again.


    Best regards



  • 8.  RE: UIA Spy method not working

    Posted 8 days ago


    For what it's worth, we had exactly the same issue yesterday. It was fixed using the solution above, but using the parameter --force-render-accessibility=complete when launching Edge, instead of just --force-render-accessibility.

    Hopefully yours will be fixed as easily - the hardest part was finding the fix!


    John Wilding
    Robotic Architect
    ReAssure Ltd

  • 9.  RE: UIA Spy method not working

    Posted 8 days ago

    Hi John.


    Thanks for the feedback. I have passed the info back to the other Developers to implement. Lets hope it fixes our issues as well.


    Kind regards



  • 10.  RE: UIA Spy method not working

    Posted 6 days ago

    Hi John and Team.


    The fix did work on many of the Objects, however we still have some, that did not work and we don't know why, yet.

    Has anyone else experienced this ? We did apply the change to all the objects.

    Fortunately, all my processes are running again, but I have a few Developers who are still battling.


    Kind regards