Showing results for 
Search instead for 
Did you mean: 

No conversion available from Text to Collection

Level 4

Internal : Failed to translate data - No conversion available from Text to Collection


Can anyone tell me how to fix this?



What if you set the new name on a variable before using that action ? Avoid sending the function in the action, instead, use a text variable with the new name 


Daniel Sanhueza
RPA Professional Developer

I tried but it won't work, Daniel.


Here is the flow

Uhmm thats weird. What if you hardcode the path and the new name ? Just to see if the error persist


Daniel Sanhueza
RPA Professional Developer

If I hard code that value means it is working, but my file name is dynamic one.

Hello! Sorry for my late response. Yes, I just wanted to know if you hardcode the error persist, it isnt the case so I think there's some troubles with the collection not being initialized but this is only a guess, I tried to replicate your error following your same steps but then I realize that my Utility - File Management isnt updated so I will asume that you have the updated version from Dx, wich I couldnt download because cant login 😭 due an error that doesnt compete with this topic (Good luck chases me but I'm faster 🤣). I couldnt came to reply on this empty handed so what you can do is not use "Rename File" action, instead use this secuence of steps:

  1. Utility - File Management:Get Files
  2. Utility - File Management:Split Path -> To get the folder and filename
  3. Utility - File Management:Move File -> Send [Files.Path] and on Destination Path, send the Folder+ the replace function that you have.

I tested this, and the result it the same file with the new name on the same folder.


Daniel Sanhueza
RPA Professional Developer

This expression is wrong buddy. Please use the below one

Replace([Files.Name], ".xlsx", FormatDate(Today(), "dd.MM.yyy"))&".xlsx"

Amlan Sahoo