Showing results for 
Search instead for 
Did you mean: 

OLEDB - errors on Open Connection

Level 4


Process Sets Connection using below string 

Provider=Microsoft.ACE.OLEDB.12.0; Data Source=\\cefil0520\GLEAM\Gleam_MI\ZURICHUKMI_PolicyRisk_20231104_161918.txt; Extended Properties="Text"

Then when attempts to Open, it gets this error:

Could not execute code stage because exception thrown by code stage: '\\cefil0520\GLEAM\Gleam_MI\ZURICHUKMI_PolicyRisk_20231104_161918.txt' is not a valid path. Make sure that the path name is spelled correctly and that you are connected to the server on which the file resides.

The path is valid and the file does exist, does anyone know why I would be getting this error?

The text file is too large to open manually if that would have any impact. 


Level 11

It seems OLEDB does not support UNC specification of data sources.

I have tried something like: "p:\folder\file.txt" to address a file on a network share and it worked.

When taking the UNC version of the file location "\\server\folder\file.txt" I got the same error that you mentioned.