Showing results for 
Search instead for 
Did you mean: 

MFA error while using Microsoft Graph Authentication VBO

Hi All,

I have implemented a solution that using Microsoft Graph API to Integrate MS Teams.

The solution worked fine using delegated access token action for authentication with dev bot id.

But when moved to prod with a new bot id and new VM , the authentication is not working.

Please note we are using same client id , client secret & tenant id for both dev & prod BOT ID.

Getting below error.

{"error":"invalid_grant","error_description":"AADSTS50079: Due to a configuration change made by your administrator, or because you moved to a new location, you must enroll in multi-factor authentication to access '00000003-0000-0000-c000-000000000000'. Trace ID: 15114538-6ccd-497b-8521-129986ae3a00 Correlation ID: 8289e125-5004-4e82-91bc-7e619a3f1444 Timestamp: 2024-04-08 10:12:06Z","error_codes":[50079],"timestamp":"2024-04-08 10:12:06Z","trace_id":"15114538-6ccd-497b-8521-129986ae3a00","correlation_id":"8289e125-5004-4e82-91bc-7e619a3f1444","error_uri":,"suberror":"basic_action","claims":"{\"access_token\":{\"capolids\":{\"essential\":true,\"values\":[\"08751b15-34db-441c-954c-38a6af8f8513\"]}}}"}


Action used : Get Delegated Access Token.



Your advice will be helpful, thanks!



Are you able to still connect to the MS teams in your Dev environment? . Based on the error message, it looks like MFA is enabled. Did you tried turning off the MFA?

Please refer



@KamineePrakashGurav Looks like MFA is enabled in your prod. Please use latest version of that supports action to deal with MFA.

Alternatively you may contact your IT team if they can disable MFA for you.

Thankyou for your advise , I will try it.

Thanks for your advise , let me try this as well.