Showing results for 
Search instead for 
Did you mean: 

Chrome - Browser Mode cannot recognize previously spied elements

Level 3
OS: Windows 7   BP Version 6.4   Browser : Chrome I am having an issue where previously spied elements are not being recognized in App Modeller. I am using Browser Mode to spy elements in  ANY web page within Chrome browser. App Modellar was functioning fine for few days but all of a sudden it was not able to recognize any elements. Troubleshooting steps included clearing cache from browser, reinstalling BP 6.4, using different credentials to log into OS and BP, creating a new object, comparing attributes before and after the issue. I can use UIA for this web application in Chrome by enabling force render accessibility, but the attributes it is finding is not satisfactory. Constantly using match index is required but the result is not consistent.  That said I would like to use Browser mode which resulted in better attribute selection. Unfortunately , i have the issue of elements not being recognized. Any guidance on solving this issue is much appreciated. Thanks Prav.

Level 3
Often elements not being able to be spied any more is due the the attributes changing from time to time on the site, or your attributes being too specific. One option is to copy the values that are currently in the attributes, to keep them for reference, and then remapping the element to see what has changed.  

Level 14
You may have done this already, but I would suggest searching for 'chrome' in the BP forum here and read all the posts in the last 2 weeks or so where others have been having issues with spying Chrome. The various issues are usually caused by the Chrome 72 update. Chrome 71 spying in browser mode works in Blue Prism, but Chrome 72 does not. I heard that the 73 beta update works, but I have not confirmed that myself. However, I have tested/confirmed myself that Chrome 71 spying in 6.4 works whereas Chrome 72 simply doesn't work at all with browser mode.
Dave Morris 3Ci at Southern Company Atlanta, GA

Level 2
Hi, i confirm that on chrome spying is ok, but no highlight is possible! the only way is downgrade (with some difficult) to chrome 71 and disable chrome update. But we cannot force customer to do this! There is another way to avoid this problem? Regards Stefano 

We were facing the same issue and managed to find a solution. When in chrome, navigate to flags (type: chrome://flags in search bar) Search for Enable network service flag and Disable it. For us that fixed the issue mentioned above

Level 4
Thanks for the tips pwisniewski, had the same problem as Praveen and your solution solved the problem.    BR   Zahib 

Level 3
I am also having the similar problem when i have done entire my process in 71.X and after one week chrome was updated to 72.X then it does not work(Not able to identify the elements).So I have uninstall chrome and installed version below 72.X then its started working but chrome always updating .So we are not able to run the process.

Level 2
thank you pwisniewski Worked for me.

Level 3
 Many thanks ""pwisniewski"" it worked perfectly for me.I was struggling entire day and finally make the changes and its working fine.

Level 2
Hi -  I made pwisniewski change but.. I'm not able to recognize or identify an object in Chrome page. could you please help me here?