Showing results for 
Search instead for 
Did you mean: 

Could not find installable ISAM.

Level 2
Hello All,
Need your expert opinion here.  I am using Data OLEDB Utility to connect to excel, I am providing following connection string as data item, and each time it is giving me "Could not find installable ISAM" error. I have tried to pass connection string as well formatted Text also. Currently I am using 32 bit office products and downloaded 32 bit microsoft 2016 redistributable component(Tried with 2010 as well). Let me know if any other information is required.

connection string as data item = Provider=Microsoft.ACE.OLEDB.12.0;Data Source="C:\Users\Downloads\Sample.xlsx";Extended Properties="Excel 12.0 Xml;HDR=YES;"

Best Answers

We have the following KB Article, "How do I configure the OLEDB VBO to query an Excel file."

If you keep having the issue, please let us know.

View answer in original post


We have the following KB Article, "How do I configure the OLEDB VBO to query an Excel file."

If you keep having the issue, please let us know.

Level 2
Hello Luis
Thanks for that article. I passed database and provider as different arguments rather than forming connection string. It worked. Thanks a lot 🙂

I tried opening the link provided, but it shows me a page containing only header and footer, no page body. Has it been moved, or does it require some special access?

Level 4

I have updated to the latest 10.1.0 versjon of the Data - OLEDB object.

I have installed

  • 64bit version of Microsoft Access database engine 2016 (English)
  • Blue Prism 7.3.0 (64bit)
  • Microsoft Office 365 with Excel version:
    • Microsoft® Excel® for Microsoft 365 MSO (Version 2403 Build 16.0.17425.20236) 64-bit

The pc has been rebooted after install.

I run Set Connection with the database input set to:


"C:\Temp\Avstemming periodeslutt 1297 Apr24.xlsx";Extended Properties="Excel 16.0 Xml;HDR=YES;"


I provide no other inputs to the action.

The action creates the Connection String:


Provider=Microsoft.ACE.OLEDB.12.0; Data Source="C:\Temp\Avstemming periodeslutt 1297 Apr24.xlsx";Extended Properties="Excel 16.0 Xml;HDR=YES;";


I then run the Get Collection action with the SQL input as follows:


FROM [Åpne poster 30.04 etter]


The first thing the action does is to run through the "Open" action, which generates the error:


Internal : Could not execute code stage because exception thrown by code stage: Could not find installable ISAM.


I have tried figuring out what causes this, but can not see the issue.
I have also tried providing "Microsoft.ACE.OLEDB.16.0" as provider input, without seeing any difference in the result.

The link above is broken, and any other resource I have found on the topic has not gotten me anywhere.
Does anyone here know what the problem might be?


Try changing the "Excel 16.0 Xml;HDR=YES;" to "Excel 12.0 Xml;HDR=YES;".

We run the following provider string with our Excel 365 (64 bit) without issue:

Microsoft.ACE.OLEDB.12.0;Extended Properties="Excel 12.0;HDR=YES;READONLY=TRUE;IMEX=1"

We put the path to the Excel file into the Database parameter.


Micheal Charron
Toronto, Ontario

Thank you!
That seems to have fixed it. 
I was sure you'd have to input the current version of excel. I guess not. 🙂

Also I had set only the Sheet name in the FROM statement. but you need to include the columns as well it seems. So for anyone that might come across this in the future. 
Make sure that your from statement looks like this 
FROM [Sheetname$column:column]

Hi @andber ,

I have seen this error in past as well and this usually happens because of incorrect Extended Properties parameter. Can you try the below connection string:


Provider=Microsoft.ACE.OLEDB.12.0; Data Source=C:\Temp\Avstemming periodeslutt 1297 Apr24.xlsx;Extended Properties="Excel 12.0;HDR=YES;"


 I have basically modified the Extender Properties from Excel 16.0 Xml to Excel 12.0. Also, I have removed the surrounding double quotes from the file path which technically should not make any difference and also have removed a trailing semi-colon which is not needed.

As you can see with my connection string, I am able to get the collection:



But if I use the one with your extended properties, I get the same error as highlighted below:


Please check the same and let us know if it works.

Hope it helps you out and if my solution resolves your query, then please mark it as the best answer

Devneet Mohanty
Intelligent Process Automation Consultant | Technical Business Analyst,
WonderBotz India Pvt. Ltd.
Blue Prism Community MVP | Blue Prism 7x Certified Professional



I was concentrating on the ISAM problem so much I did not notice your SQL query:

FROM [Åpne poster 30.04 etter]

If you want to query your entire Excel worksheet, you don't have to specify the columns in your FROM clause but you do have to append a "$" to the end of the sheet name:

FROM [Åpne poster 30.04 etter$]

You can specify the addresses of a range after the "$" which is really handy if your data starts from a row other than the first. If you leave out the "$" after the worksheet name, the OLEDB assumes you are trying to query data in a Named Range.


Micheal Charron
Toronto, Ontario

Thank you for taking your time to reply @devneetmohanty07 . MichealCharron had already responded with the modification from 16 to 12 on the excel version, and it was the magic bullet. All is well on the ISAM problem now. Thank you.