cancel
Showing results for 
Search instead for 
Did you mean: 

Decipher Licensing Service status is stuck at "Starting"

LeandroVelo
Level 2

Hi,

After all the insane installation and configuration of this tool, I finally got the login page and tried with the "admin/admin" set of credentials and it failed. The message was: 

A connection cannot be established because the destination computer expressly denied the connection 127.0.0.1:12543

I'm facing this issue and I've found no answer yet. The 4 services are available but Decipher Licensing Service is stuck at "Starting" and Decipher Server stops as soon as I force it to start.

Any idea or known solution?

Thanks in advance,



------------------------------
Leandro Velo
------------------------------
3 REPLIES 3

Ben.Lyons1
Staff
Staff

Hi Leandro,

The licensing service can get stuck starting if the services it relies on haven't started e.g. RabbitMQ.

I recommend setting the service start up to "Automatic (Delayed Start)", this should only happen when the host server starts up or is restarted.

If the service is stuck, you can either restart the server (with the setting above amended) or force it to stop via command line.

NB - Always be careful when forcing services to close and only do so if you are experienced in server management.

Execute this:

sc queryex BluePrism.Decipher.LicensingService

Then add the PID in this action, in place of %%%%

Taskkill /pid %%%% /f

You should be able to start it after that, assuming your configuration is otherwise correct.

Thanks



------------------------------
Ben Lyons
Senior Product Specialist - Decipher
SS&C Blue Prism
UK based
------------------------------
Ben Lyons Senior Product Specialist - Decipher SS&C Blue Prism UK based

Hi Ben, thanks for your answer.

RabbitMQ service was running, Decipher server was stopped and Decipher Licensing Service was stuck at "starting". I killed the service as you suggested, changed the configuration, then I started it and it went the same way. Decipher Server stops as soon as it starts, I guess because the licensing service is down.

 I've already re-installed the Licensing service and checked the database connection.

Is this the reason why the login into the Decipher portal is failing? Is there any other reason why it could be happening?



------------------------------
Leandro Velo
------------------------------

Hi Leandro,

It might not have been running when the licensing service attempted to start, but there may also have been another dependant process that hadn't started.

It's hard to say, but first thing I'd check is the database permissions - Decipher IDP post-installation configuration (blueprism.com).

Failing that, it would be best to raise a support ticket.

Thanks



------------------------------
Ben Lyons
Senior Product Specialist - Decipher
SS&C Blue Prism
UK based
------------------------------
Ben Lyons Senior Product Specialist - Decipher SS&C Blue Prism UK based