Showing results for 
Search instead for 
Did you mean: 

Issues Clicking a Save & Close Button


Hi all,

I am having the following issue with a current process I am working on.  The process involves taking a list of new investors, logging on to a webpage, and entering the new investors into the system.  I am able to navigate all the menus and buttons except for the last button when I am trying to Save and Close the new investor window.  

Below is the application modeller I've used to spy the button and a screenshot of the webpage.  Blue Prism is definitely recognizing the button because when I run the process it does not stop on that button, it acts as though it has clicked the button, but I am not seeing that on the web page.  I am also able to highlight the button in the process.

Any thoughts on how to resolve this would be greatly appreciated.  Thanks!




Also, when looking at the below when comparing the Save and Close button to the close button, I noticed a difference in some of the coding.  The main difference I am seeing is that the Save and Close button has "StandardEditorPage.saving = true" and that button is not working and the close button does not have that and it is working.  Thank you




Hi Griffin- Elis,
Are you able to  do it manually, the issue is only when BOT is  trying to click the element? 
Based on your  response, I will try to summarize the issue
You have spied  the element in browser mode - it is able to successfully identify the element  and also highlight the element
you have tried:
 1) focus + global send keys and/or Global send key events  to select the button
2) Tried UI mode but unable to identify the element
3) Focus+Global Mouse Click
based on other members response  it looks like you have tried changing the app modeller element but it is not working
So what i suggest  is try to use combination of actions  you might need to perform some trail and error  to overcome this issue 
1)Highlight+Focus+Click center+Global send keys/global Send Key events(try enter)
2) Highlight+Focus+press
3) Highlight+Focus

Also make sure  to perform some global send keys or/And global mouse click the action  before  Save and close  button
Once it is working you can always refine the elements which are required.

Let  me know how it goes.

If I answered your query. Please mark it as the Best Answer

Harish Mogulluri

Hi Harish,

Yes, I am able to click the button manually.  And your summary is correct and I have tried all of those options.  I will go ahead and try other combinations of actions as well to see if those work.  I also wanted to ask about two other items.  Do you have any training material on how to use "Invoke Javascript Function" in the navigate stage?  I am thinking that could be a way to save and close without having to click the button.

Secondly. do you think it is possible there is some sort of blocker on this website preventing a BOT from clicking these buttons.  I went to a different, but similar menu on the website and tried spying a "Save" button as well as another "Save and Close" button and was not able to click any of those as well.  I'm curious to your thoughts on a blocker being a possibility.  Thank you!

Hi all,

Any thoughts on the above and the possibility of their being a blocker preventing BP from performing the Save and Close event?  Thank you

Hi Griffin-Elis,
I have shared video related to Invoke Java script. Also refer  the B P document below on how to enable javascript fuctionality

To my opinion if it is working manually but not  through bot, I think  one of the field   might probably expecting  global send keys instead of click or Write stage to enter the values

 I will check below approach
 Let bot run till the save and close button and try to click the save button and see how the application responding - if  you encountered same behavior then save button is expecting some  human clicks in one of the filed. - I Would give a try on this

If I answered your query. Please mark it as the Best Answer

Harish Mogulluri

Level 7

Hi @Griffin-Elis ,

From the screenshots you've shared, I can see the element types as Hyperlink(browser spy mode) and edit box(UIA Mode). Try changing that to Button type and give it a try also check if Inner Text attribute is present. Unselect the attribute web page address.

Babjee Vangipurapu
Senior RPA Developer

Level 3


Check only web class and match index =1, in the matching attribute. In Navigate drag and drop spied element use focus and then Click. It'll work most of the time. 

or If you have option to spy in UIA mode. You can use that and check webtext and match index. Then use the UIA spied element in Navigate , First Focus then global mouse click centre.