Showing results for 
Search instead for 
Did you mean: 

LOGIN AGENT: Exception thrown by code stage: Object reference not set to an instance of an object.

Level 5

Hi All - I am currently seeing this error while using Login Agent. We use HTTP request to retrieve credentials from CyberArk and then send those credentials to Login Agent. I have suddenly started seeing this 'object reference not set to an instance..' error. Not exactly sure what or where the error is occurring. Has anyone seen this issue before and what are the potential solutions?

Thanks in advance!


Did you test the request externally to BP? Postman for example?
I already had a similar problem with the action, in this case it was passing one of the null arguments. Check if this is the case.

Leonardo Soares
RPA Developer Tech Leader
Leonardo Soares RPA Developer América/Brazil

Hi Leonardo - I was able post the URL on a browser and get the results but while trying to access via BP - I am seeing that error. I've tried installing the latest Utility-HTTP and when I run through that I am seeing a new error 'The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel' .. Not sure which utility is correct and which is the actual error at this point. 

What was the solution in your case.? For which parameter were you passing the null argument?

Thank You,

Maneesh Vemula

Update on this. The issue turned out to be certificate related. We had to renew the certificates. 


Maneesh Vemula