cancel
Showing results for 
Search instead for 
Did you mean: 

PCSHLL32.dll loading failed for IBM Iaccess solutions Acs while launching

Suresh_BabuYada
Level 2
Hi All,

PCSHLL32.dull loading failed while launching and unable to attach to mainframe app 

inplaced the dll in BLUEPRISM automate folder and systemwow and system folders

but still same error load failure received

can someone throw a solution 

thanks

------------------------------
Suresh Babu Yadagiri
Consultant

------------------------------
4 REPLIES 4

gmarquez
Level 6
Hi Suresh,

I am guessing that you were following our KB article.  There are some additional steps you could possibly try:

How to resolve this issue

Search "PCSHLL32.DLL" file on the client machine and then:

  1. Copy PCSHLL32.dll to your "C:\Program Files\Blue Prism Limited\Blue Prism Automate" directory.
  2. Copy PCSHLL32.dll to the Windows system directory.

The %windir%\system variable retrieves this directory's path for 64-bit files on a 64-bit OS, and 32-bit files on a 32-bit OS. For 32-bit files hosted on a 64-bit OS the directory is %windir%\SysWOW64 


However, if the file "PCSHLL32.DLL" does not exist in the client machine, or if the first solution does not resolve the issue, then please do the following:

  1. Check the following folder exists and has the "C:\Program Files (x86)\IBM\EHLLAPI" and has the "PCSHLL32.DLL" file in it.
  2. If the folder does not exist, then contact your company IT team and request them to install the "EHLLAPI" package. This package is provided by IBM and needs to be installed in the Mainframe Emulator application into the client machine.
  3. After the package is installed, repeat solution one to update the "PCSHLL32.DLL" file in the Windows OS system and Blue Prism folder.

 



------------------------------
Gabe Marquez
Technical Support Engineer
Blue Prism
------------------------------

Hi, 

I already performed above but still getting same error while trying to attch "Internal : Failed to perform step 1 in Navigate Stage 'Attach' on page 'Attach' - Terminal Emulation - Could not load the dll - PCSHLL32.DLL"

can someone help on this?



------------------------------
Preeti Bisen
------------------------------

Hi Preeti,

Check knowledge base solution 2. https://support.blueprism.com/en/support/solutions/articles/7000078188-bpe-error-failed-to-launch-application-launch-failed-terminal-emulation-could-not-load-the-dll-

Regards,



------------------------------
Leonardo Soares
RPA Developer
América/Brazil
------------------------------
Leonardo Soares RPA Developer América/Brazil

Hi Team we are still facing the missing DLL error while Launching the mainframe from BP, although both DLLs are available in the BP folder, IBM folder, and System folder. Any idea what am I missing here?