Showing results for 
Search instead for 
Did you mean: 

7.1 update - messaging host - unknown browser type

Level 2
Hi all,

Looking for some advice. We've upgraded to v7.1 tom 6.8, but have an issue with the messaging host connecting up to Chrome. Some of our virtual machines work ok, but some don't, and I can't see any reason for the difference.

When I try to launch on the affected machines, chrome is launched and appropriate website appears but then shortly after I get the following error:

Internal : Failed to perform step 1 in Navigate Stage 'Launch' on page 'Launch' - The browser extension was not detected, please check that it has been installed and enabled. For more information, see the browser extension user guide.

I've gone through all the various steps suggested on the knowledge base articles to resolve, but nothing has worked so far. I have also checked on windows event viewer and have seen the following error:

Error connecting to pipe, the Named Pipe failed to connect and timed out

I have also run the log tracing and get the below key lines:

2022-11-21 14:26:08.5782 ERROR BluePrism.MessagingHost.Program System.NotSupportedException: Unknown browser type
at BluePrism.MessagingHost.Program.b()
at BluePrism.MessagingHost.Program.Main()

Any idea's on how I can resolve this? Especially given that I have machines that do work, but I can't see any differences between the various manifest files, registry entries, extension versions, chrome versions etc.

Thanks in advance,

Hey Ricky, I hope you are doing well. On the knowledge base article here, you said you tried several steps. Did you attempt the step "Windows Performance Counters are not enabled"?

From doing a bit of research internally here at Blue Prism, the error message "Unknown browser type" is popping up in relation to the Window Performance Counters mentioned in the KB. 

Let me know if this is something you already tried in your testing, and if you haven't tried it, hopefully it helps to resolve your issue.
Jacob Clary Senior Product Support Engineer Blue Prism

Level 2
Hi Jacob,

I did briefly look at that section and found that the machines actually didn't have a registry entry at all for Disable Performance Counters, but tried nevertheless to add an entry in with a 0 value, but that didn't make any difference, so I moved on.

However following your response though, I went back to that aspect, and went into cmd to rebuild the performance counters, which looks to be the solution for the issue.

Might be worth adding that into the knowledge base, if anyone else runs into that issue.

Thanks for the guidance though!


Level 3

Hi Ricky,

Currently I am facing the above mentioned issue. have you found any solution for this?

The support link is not working. I really hope the redirects are put properly in place to all the support KB articles.