Showing results for 
Search instead for 
Did you mean: 

Chrome automation difficulties

Level 9
Hey folks. I just changed one of our processes over from Internet Explorer to Chrome. We just moved from v5.24 to v6.10.1; I had been looking forward to using Chrome instead of IE, although I was not anticipating some of the difficulties. I was wondering if anyone else has experienced similar issues, or if anyone has any ideas to help.

• Failing to connect to Chrome extension

This has happened on a couple different machines, seems to be random. Correct version of the extension is installed, reinstalling it has no effect.

• Missing Navigate option

I do not have an option to navigate the window to another page when I use the Chrome automation method in Application Modeler. I had to get around this by inserting a javascript fragment containing code to change the URL, and then executing the fragment.

• UIA mode slowness

UIA mode seems excessively slow to find/write things to elements.

• UIA mode causing Blue Prism to hang

Certain elements spied in UIA mode causes Blue Prism to permanently hang. It does not crash, which would honestly be preferred; it hangs forever. The hanging occurs when highlighting certain UIA elements, or attempting to interact with them via a wait/read/navigate stage.

• Parent document loaded does not seem to function correctly

A wait stage on Parent Document Loaded keeps reporting the document is loaded while Chrome is clearly showing it is still loading the page. I've encountered similar difficulties in v6.10.1 on IE where Parent Document Loaded never reports the document is loaded. Parent Document Loaded worked mostly fine in IE in v5.24.

• Element not found after wait stage reports the element is found

This particular page contains CSV data that we are attempting to read. We have a wait stage that specifically waits for this element to appear before we attempt to read it. The wait stage will report the element is present, but when we go to read the text out of the element, Blue Prism errors out saying the element cannot be found. I suspect part of the problem is that the element has a lot of text that is being written into while the page is loading; it is possible the wait stage is detecting the element, but since the contents of it are still being modified, it may be what is causing the read stage to fail. I would have expected a different error message than stating that it cannot find the element were this the case, however. This one would not have been a problem if the parent document loaded issue above were fixed.

• Times out while reading text from large elements

Related to the situation above, once this large block of CSV text has been loaded into an element (something like 800k characters), Blue Prism is repeatedly failing to load the CSV data, reporting an Operation Timeout exception. My best guess on the error is that internally Blue Prism has a timeout when reading an element. The only work around I found was to have it select the text and send a Ctrl+C to copy it the clipboard. Not exactly an ideal fix.

• Wait stage fails to find an element if another element in the wait stage has an error

I have a wait stage checking for one of three possible elements to appear. The elements are all spied in browser mode. One of the elements is inexplicably getting a "target of invocation has disconnected" error, even though it is very much similar to the other two elements, with the only difference being the value of the filters.

In this wait stage, the element that is getting the error is the first one. The second element in the wait stage is the element that, in this specific case, exists. If I have a wait stage with only the second element that exists, it correctly detects that it exists and continues. In the wait stage with both the element that is having an error and the element that exists, it does not report that the second element exists, even though it does. Instead, it times out. I would expect either an error to happen if it is unable to successfully check for available elements, or for it to correctly report that the second element exists.

(I may be able to resolve this one by simply restarting Blue Prism or respying the element or some such. However, the behavior of the wait stage is unexpected.)

Nicholas Zejdlik
RPA Developer

Hi Nicholas,

I got all those issue from 6.4.3 . It is so frustrating. I don't know how blue prism is going to tackle with modern browser ini future. For now it's not good at all. At least 6.4.3 i much much better a compare to 6.10.1.
Sometimes it is a pain to automate things in Chrome using BP.

Important thing they are aware about those issues but instead focusing on all those which is very important than anything else, they are focusing on other stuffs.

Even I raised multiple support tickets and multiple idea on ideas section but all went in vain.

Amlan Sahoo
RPA Consultant
Amlan Sahoo

This isn't the first time I've seen concerns about support or about the core product on the forums. I'm glad to see Blue Prism releasing new content fairly frequently, but I would like to see some more focus on the core product. The extra stuff really does not matter to me if my ROI is decreased due to the extra time spent working around technical problems. It seems the focus on new products some developers feeling left behind.

On a side note, I tried using the Playwright library that Microsoft released for headless Chromium/FireFox/WebKit browsers, and it works very well, much more like what I would hope to see from Blue Prism. Unfortunately I could not get the library to function in Blue Prism due to the need for netstandard.dll, which I had problems getting Blue Prism to reference. If I could get it work in Blue Prism, I would likely start using that library for Chrome automations instead.

Nicholas Zejdlik
RPA Developer

Level 14
Hi Nicholas,

First, let me just say that I'm right there with you on the frustration. I've been dealing with things like this over the course of Blue Prism 6.3 to 6.10.1. With each new version, some issues appeared to be fixed, but something else would happen or the same issues would come back. Overall, Chrome automation did get MUCH better from 6.3 to 6.10.1. I find it to be pretty reliable in 6.10.1, but the latest version I'm involved in where a client has it in production is 6.9 so it's hard to confirm for sure.

In any case, you're seeing some of the same issues I've experienced, and I'd like to comment on each one of them, if nothing else but so that you know you're not crazy. 😃 In some of the cases, I can suggest workarounds, I think.

But, bottom line up front here, I'm liking v7.0 with its new native browser messaging component or whatever it's called. It has worked flawlessly for me so far, but of course it still is missing some features you've mentioned. I'm still doing some testing around that. I hate suggesting v7.0 because I know you've been around for a while and already know the common suggestion of "Oh just upgrade and your problems will be solved!" Haha!

• Failing to connect to Chrome extension

This was supposed to be fixed in 6.10.1. It was a common issue I ran into in 6.10, and it was one of the things they tried to fix. The setting I'd suggest for attempting to troubleshoot is in the System tab > System group > Settings > and all the way at the bottom under "Browser Extension Connectivity" > "Use fixed browser extension port (31924) only". Checking this box turns ephemeral ports off. Unchecking the box turns ephemeral ports on. The trade off is that with the box checked, things should work similarly to early versions of v6 where only port 31924 was used, which causes more functionality to work properly but with the increased chance of the connectivity breaking, requiring a restart of the browser and sometimes of the runtime resource. If you have the box unchecked, then it should be more reliable as far as connectivity goes, but instead some functionality doesn't work such as trying to attach to browser windows that Blue Prism did not open originally. Overall, this issue has been a thing for quite a while across a number of versions and it's the one that makes me want to tear my hair out the most.

• Missing Navigate option

The Navigate stage action you want is called "Set Address". If I remember right in IE automation, it was called "Navigate URL" or something. It works the same though. You're gonna facepalm on this one, and it's ok because I did the same thing. Blue Prism didn't stay consistent here. Originally in Chrome automation, this did not exist at all. I think it wasn't added until maybe 6.7 or so. I'm not 100% sure on that though. I have no idea why they didn't name it the same thing.


• UIA mode slowness

Yeah, it's slow. It's the worst. I basically attempt to never use it. When I do use it, I cry softly to myself. Luckily, Blue Prism has been adding some Global Mouse stuff to Browser mode. Now we just need a Global Mouse Click in Browser mode, and we may not ever have to use UIA in browser automation. You can technically use Active Accessibility if you're like me and found that it was faster than UIA mode in IE automation. You just have to change the Application Type from browser to desktop temporarily while you spy AA elements and then you can switch it back to Browser, and it will retain the AA elements and they'll still work.

• UIA mode causing Blue Prism to hang

This is a fun one. I have zero workarounds to suggest for it, but that or something similar has happened to me. It doesn't happen very often for me though.

• Parent document loaded does not seem to function correctly

I hadn't noticed the exact issue you described with Parent Document Loaded. I'm with you on how important that is in Wait stages. I used to use it all the time in IE automation. Chrome automation didn't used to have this at all. I think it wasn't added until like 6.9 or something, so I think they still have some stuff to work out for that. The issue I ran into is that Blue Prism would report that it couldn't find an element even though the element was loading within the timeout timeframe. The issue intended up being a problem with the browser extension that they fixed after I reported the bug. It didn't require a change to the core platform. As a side note, I'd also like to see Document Loaded added in as well and for them to function like they did in IE.

• Element not found after wait stage reports the element is found

I'm gonna say I'm 70% sure I or colleagues of mine have had this issue, but we could never reproduce it reliably enough to report it. as a bug. If you can reproduce the error, I think that would be very valuable for Blue Prism to know how to do so they can fix it.

• Times out while reading text from large elements

I cringed when I read your workaround to it. That must be painful. I'd say the same thing as above is that you're probably right about the issue and I super encourage showing Blue Prism how to reproduce that error if possible. I don't think I've had that use case so I haven't run into that issue.

• Wait stage fails to find an element if another element in the wait stage has an error

I believe I've run into this as well, but again it's kind of hard to reproduce. But I 100% agree that wait stages should attempt to evaluate all conditions before giving up just because one of them had an error. Actually, maybe a good suggestion for Blue Prism is to make it a toggle-able setting in a wait stage to say "throw an exception if there are any errors" or something similar to that.

Dave Morris
Cano Ai
Atlanta, GA
Dave Morris 3Ci at Southern Company Atlanta, GA

I am using BP 6.6, with Crome. I have putted Wait condition, But It not work.

Amit Kumar

Hi Amit,

Preferably, next time create a new thread for your issue, as the one you re-opened above was both old, had been solved, and is seemingly unrelated to your new question.

Now to your question:
Please enhance the part where you state it doesn't work. Do you get an exception? If so: what does it say? Can you highlight the problematic element in the object modeller? If not: why's that?​

Dear folks at BluePrism:
Here's another one new-old thread opened. Are we gonna fix this? 

Happy coding!
Happy coding!
Paul, Sweden
(By all means, do not mark this as the best answer!)