Showing results for 
Search instead for 
Did you mean: 

Issue with Outlook VBO

Level 2


I have been using MS Outlook Email Vbo object to work with the shared mailbox. It worked perfectly good till last week. Since then I started to receive following error:

"Internal : Could not execute code stage because exception thrown by code stage: Unable to cast COM object of type 'System.__ComObject' to interface type 'Microsoft.Office.Interop.Outlook.Folder'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00063006-0000-0000-C000-000000000046}' failed due to the following error: Error loading type library/DLL. (Exception from HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY))."

Issue started after last office update on virtual machine. We tried to repair whole microsoft office package, we uninstalled office and installed it one more time. Strange thing is that after office update in automate folder we had 2 libraries:
1. Microsoft.Office.Interop.Outlook.dll
2. Microsoft.Office.Interop.Outlook.dll_OLD

we tried to rename both of them to Microsoft.Office.Interop.Outlook.dll and use one at the time but it didn't work either. 

Do you have any idea how we can act in such situation? 


Level 2

Hi Harish,
We checked and on virtual machine we have only one folder for version 9.6  for outlook registry. Below is the screenshot from registry which is corresponding to the information from error in the Blue Prism. 

What is more we were not able to locate file for win32.

As you can see there is only version 9.6 so in theory the correct one. Do you know if there is some other way to check registry?

Following some other tips we tried to repair the office package but in control panel there is not any office application on the list which is strange - regarding this problem we already contacted out internal it department. 


Do you know what else we can do to make robots work?