Showing results for 
Search instead for 
Did you mean: 

Run exe using Blueprism

Level 2

Hi all,

Can someone please guide me how to run an exe file using blue prism VBO. Tried using utility environment;start process, when i passed the command in arguments its exiting the stage and the script is not running. Please help.

Thanks in advance

Krishnapriya MM

HI Krishnapriya,

In general start process will work. can you provide more details  what exe file you are trying to launch? And what is the expected result?

Did you get chance to try with out passing arguments?

If I answered your query. Please mark it as the "Best Answer"

Harish M
Lead developer
America/New_York TX
If I answered your query. Please mark it as the Best Answer

Harish Mogulluri

We are experiencing an issue with VBO - Utility Environment, Action: 'Start Process' on version 7.2. On our old version we could send values for 'Application' such as: "msedge" or "msedge.exe" or "notepad" or "chrome" and it would launch those apps. We found that on 7.2 sending a complete file name: "C:\Users\BOT\Desktop\New Text Document.txt" or a URL "", successfully opens a file or default browser, but we can't send ".exe" or process names any more. However, the action: 'Start Process Read Stderr and Stdout', can still start processes by sending "notepad". We are still trying to get to the bottom of the issue. In general it seems to work if you send complete file names (not file paths to exe's).

Stephanie Strydom

Hi Stephanie Strydom,

I tried to replicate the same on 7.2 and it is launching apps just by passing the name same as ealier. I tried "notepad", "chrome" and "msedge" and all 3 worked for me without passing the full path.


If I was of assistance, please vote for it to be the "Best Answer".

LinkedIn -

Thanks & Regards,
Tejaskumar Darji
Sr. Consultant-Technical Lead

Hi Stephanie,

Blue Prism 7.2 Utility environment VBO Issue | Blue Prism Product here you may find your solution. Please have a look at the same.

Amlan Sahoo
Senior RPA Consultant
Amlan Sahoo