Showing results for 
Search instead for 
Did you mean: 

Browser extension not detected

Level 3


While launching a site using chrome encountering below error in Navigate stage.

ERROR: System  Exception : Failed to Launch Portal: Failed to perform step 1 in Navigate Stage 'Launch' on page 'Launch' - The browser extension was not detected, please check that it has been installed and enabled. For more information, see the browser extension user guide.

The issue happens intermittenly.

Version of BP is 6.10.3 and browser extenstion is 6.10.3. Timeout is also in place.

Any idea what may be causing this?


Level 3

Hi Sushmitha.C,

I don't have a resolution but I'm just replying to say we get a similar issue when launching edge intermittently. I've noticed though that the exception saying the browser extension was not detected only occurs when running through the studio. When this issue happens intermittently on a schedule the exception is different:
ERROR: Internal : Failed to perform step 1 in Navigate Stage 'Launch ESR Application' on page 'Launch' - Process with an Id of -1 is not running.

From what I understand the launch action also attaches to the application, I wonder if it's trying to attach too fast? there doesn't seem to be a way to delay the attach within the launch though, or maybe I am wrong.


Ensure that the Blue Prism browser extension is properly installed and enabled in Chrome. Sometimes, updates or changes to the browser can disable extensions.
Chrome updates can sometimes affect extensions. Make sure Chrome is up to date, and if there was a recent update, check if the issue started occurring afterward.
Ensure that the extension has the necessary permissions. Go to Chrome's extensions page (chrome://extensions/), find the Blue Prism extension, and check its permissions.
Although you mentioned that a timeout is in place, you might need to increase the timeout period to give the extension more time to initialize.
As a last resort, try uninstalling and then reinstalling the Blue Prism extension.


Dear @Sushmitha.C 

Is it happening in run time machines or your development machines?

We recently upgraded our environments to version 7.3 of blueprism and had some similar issues with the browser extension. Firstly just be sure the extension you have is the same version of the application,  secondly make sure the browser is still installed on the browser. We had an issue where if the extension was installed through the BP installer it would disappear a few hours later due to group policies removing it, we resolved this by installing it directly from microsoft Blue Prism 7.3 Browser Extension - Microsoft Edge Addons

Finally even after resolving the issues with the xtension we still got some cases where the launch threw the same error youre getting. But this was a simple change in the object to catch the error on launch then do an attach and then carry on. We couldnt figure this out but for some reason the launch would sometimes throw this error and only on some of our processes not all of them, but by just doing an attach after catching the error we worked round it.

Hope this helps.