Showing results for 
Search instead for 
Did you mean: 

Click to Open Java - Chrome Popup Button

Level 2

Hi there.

We are having a new issue that is happening intermittently with regards to a Java application launching on Chrome. The particular stage in question has not seen any problems in the past until now. When trying to launch the Java application via Chrome there is a popup asking to click open the Java window. This usually works but is now failing only via the Control room run, when running in Attended mode or on debug there are no issues. The process will hang until it goes into warning. Upon highlighting and spying the field we cannot see any elements that may have changed via the recent chrome update. Screen resolution is also set to 1920 x 1080p so this has been considered. 

Unfortunately we have no workaround fix except for trial and error and to keep on trying until the button is clicked. In the code we are activating the screen and using Global Mouse click centre which works in UAT, Debug and attended modes.

Please can anyone advise what the issue may be and how we can resolve this.

BP Version: 6.7.3

Chrome: 119.0.6045.160

Java: Version 8 Update 391



Level 3

Hi Mohammad,

Unfortunately I do not have a solution/suggestion but I'm just commenting to say we are facing a similar issue. A link is clicked on an edge application which then shows the popup with the java file:
Then clicking on this opens up the java application. Sometimes this comes up in the popup first before being able to click open file:

Regardless, like yourself this all works fine apart from when we run it on the scheduler/control room where it error's intermittently. Every time I've tried to see what is happening in the VNC Window it works fine so I can't even replicate the issue, It's like it knows I'm watching lol.

I have made a change recently so that once the link is clicked on the webpage, instead of it clicking open file it instead uses the Utility - Environment::Run Process Until Ended' action on the file in the downloads folder. This had worked the other day but Today it failed on the scheduler saying it couldn't find the file in the downloads. I have a feeling that the keep button message came up and it didn't click keep for some reason, but seeing as I can't replicate I can't prove it.

Hopefully someone has some suggestions. 

BP Version: 6.10.4

Edge: 119.0.2151.72

Java: Version 8 Update 361


Raheel R